宝塔用户_clgmie 发表于 2023-10-5 15:33:21

小新 发表于 2023-10-5 15:08
你直接在百度上搜:Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)
就有解决 ...

然后就回到第一个问题了,mysqld服务启动失败

小新 发表于 2023-10-5 16:47:39

想了解下,你当时是怎样清理服务器的磁盘空间的。:D

宝塔用户_clgmie 发表于 2023-10-5 16:49:45

小新 发表于 2023-10-5 16:47
想了解下,你当时是怎样清理服务器的磁盘空间的。

就把一些日志删了而且,这个大概没啥问题

小新 发表于 2023-10-5 16:51:25

宝塔用户_clgmie 发表于 2023-10-5 16:49
就把一些日志删了而且,这个大概没啥问题

是不是也清理了tmp目录了?

宝塔用户_clgmie 发表于 2023-10-5 16:54:31

小新 发表于 2023-10-5 16:51
是不是也清理了tmp目录了?

解决了!!!

注释了这个可以了

#log-bin=mysql-bin

宝塔用户_clgmie 发表于 2023-10-5 16:55:52

小新 发表于 2023-10-5 16:51
是不是也清理了tmp目录了?

谢谢!!!!!!!!

宝塔用户_rcnnpr 发表于 2025-9-18 15:33:58

宝塔用户_clgmie 发表于 2023-10-5 16:54
解决了!!!

注释了这个可以了

虽然注释掉后可以运行了,但是binlog 就没有了。
如果之前的binlog 不需要可以
cd /www/server/data/
rm -f mysql-bin.*
或者修改配置:
log-bin=mysql-bin-new

再重启
页: 1 [2]
查看完整版本: 【已完成】在线求助!宝塔数据库mysqld服务启动失败