忘了i 发表于 2024-6-7 22:30:19

【待反馈】面板绑定域名并开启SSL访问,登录信息中的IP信

为了能快速了解并处理您的问题,请提供以下基础信息:面板、插件版本:
8.2.0
系统版本:
macos 14.2.1
问题描述:
面板绑定域名并开启SSL访问,登录信息中的IP信息显示为127.0.0.1,不显示我访问面板的真实来源IP。nginx配置文件
user www www;
worker_processes auto;
error_log /www/wwwlogs/nginx_error.log crit;
pid /www/server/nginx/logs/nginx.pid;
worker_rlimit_nofile 51200;

stream {
      log_format tcp_format
                '$time_local|$remote_addr|$protocol|$status|$bytes_sent|$bytes_received|$session_time|$upstream_addr|$upstream_bytes_sent|$upstream_bytes_received|$upstream_connect_time';

      access_log /www/wwwlogs/tcp-access.log tcp_format;
      error_log /www/wwwlogs/tcp-error.log;
      include /www/server/panel/vhost/nginx/tcp/*.conf;
}

events {
      use epoll;
      worker_connections 51200;
      multi_accept on;
}

http {
      include mime.types;
      #include luawaf.conf;

      include proxy.conf;

      default_type application/octet-stream;

      server_names_hash_bucket_size 512;
      client_header_buffer_size 32k;
      large_client_header_buffers 4 32k;
      client_max_body_size 50m;

      sendfile on;
      tcp_nopush on;

      keepalive_timeout 60;

      tcp_nodelay on;

      fastcgi_connect_timeout 300;
      fastcgi_send_timeout 300;
      fastcgi_read_timeout 300;
      fastcgi_buffer_size 64k;
      fastcgi_buffers 4 64k;
      fastcgi_busy_buffers_size 128k;
      fastcgi_temp_file_write_size 256k;
      fastcgi_intercept_errors on;

      gzip on;
      gzip_min_length 1k;
      gzip_buffers 4 16k;
      gzip_http_version 1.1;
      gzip_comp_level 2;
      gzip_types text/plain
                application/javascript
                application/x-javascript
                text/javascript
                text/css
                application/xml;
      gzip_vary on;
      gzip_proxied expired no-cache no-store private auth;
      gzip_disable "MSIE \.";

      limit_conn_zone $binary_remote_addr zone=perip:10m;
      limit_conn_zone $server_name zone=perserver:10m;

      server_tokens off;
      access_log off;

      #set_real_ip_from 0.0.0.0/0;
      real_ip_header X-Forwarded-For;

      server {
                listen 888;
                server_name phpmyadmin;
                index index.html index.htm index.php;
                root /www/server/phpmyadmin;
            location ~ /tmp/ {
                return 403;
            }
                allow 127.0.0.1;
                allow ::1;
                deny all;

                #error_page   404   /404.html;
                include enable-php.conf;

                location ~ .*\.(gif|jpg|jpeg|png|bmp|swf)$ {
                        expires 30d;
                }

                location ~ .*\.(js|css)?$ {
                        expires 12h;
                }

                location ~ /\. {
                        deny all;
                }

                access_log /www/wwwlogs/access.log;
      }
      server {
                listen 80;
                server_name bt101. xxxxxx.com;
                location / {
                        proxy_set_header Host $http_host;
                  proxy_set_header X-Real-IP $remote_addr;
                  proxy_set_header REMOTE-HOST $remote_addr;
                  proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
                  proxy_set_header Public-Network-URL http://$http_host$request_uri;
                        #proxy_pass http://localhost:8899;
                        rewrite ^(.*)$ https://$host$1;
                }

                access_log /www/wwwlogs/access.log;
      }
      server {
            listen 443 ssl;
            #配置HTTPS的默认访问端口为443。
            #如果未在此处配置HTTPS的默认访问端口,可能会造成Nginx无法启动。
            #如果您使用Nginx 1.15.0及以上版本,请使用listen 443 ssl代替listen 443和ssl on。
            server_name bt101.xxxxxx.com;
            ssl_certificate /www/server/panel/vhost/cert/bt101. xxxxxx.com/bt101. xxxxxx.com.pem;#需要将cert-file-name.pem替换成已上传的证书文件的名称。
            ssl_certificate_key /www/server/panel/vhost/cert/bt101. xxxxxx.com/bt101. xxxxxx.com.key; #需要将cert-file-name.key替换成已上传的证书密钥文件的名称。
            ssl_session_timeout 5m;
            ssl_ciphers ECDHE-RSA-AES128-GCM-SHA256:ECDHE:ECDH:AES:HIGH:!NULL:!aNULL:!MD5:!ADH:!RC4;
            #表示使用的加密套件的类型。
            ssl_protocols TLSv1 TLSv1.1 TLSv1.2; #表示使用的TLS协议的类型。
            ssl_prefer_server_ciphers on;
            location / {
                            proxy_set_header Host $http_host;
                        proxy_set_header X-Real-IP $remote_addr;
                  proxy_set_header REMOTE-HOST $remote_addr;
                  proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
                  proxy_set_header Public-Network-URL http://$http_host$request_uri;
                proxy_pass http://localhost:8899;
            }
            access_log /www/wwwlogs/access.log;
      }


      include /www/server/panel/vhost/nginx/*.conf;
}

相关截图(日志、错误):

大炮运维V587 发表于 2024-6-8 14:25:50

想使用代理,请更新到测试版,测试版使用的就是nginx代理的。

忘了i 发表于 2024-6-8 16:29:33

大炮运维V587 发表于 2024-6-8 14:25
想使用代理,请更新到测试版,测试版使用的就是nginx代理的。

正式版使用代理就会有这个问题是吗?

运维技术阿闯 发表于 2024-6-10 14:57:35

忘了i 发表于 2024-6-8 16:29
正式版使用代理就会有这个问题是吗?

本地登录的是显示这个的

忘了i 发表于 2024-6-12 21:21:31

运维技术阿闯 发表于 2024-6-10 14:57
本地登录的是显示这个的

我不是服务器本地登录,是我自己家里的网络,自己的电脑登录的。

运维技术阿闯 发表于 2024-6-13 10:46:42

忘了i 发表于 2024-6-12 21:21
我不是服务器本地登录,是我自己家里的网络,自己的电脑登录的。

您好,您到服务器SSH终端中执行下面命令(非面板终端)修复面板
删除之前无法使用的面板环境
mv/www/server/panel/pyenv /www/backup/pyenv_backup
重新获取新的面板环境和更新包
curl http://download.bt.cn/install/update_panel.sh|bash

忘了i 发表于 2025-6-17 17:54:09

运维技术阿闯 发表于 2024-6-13 10:46
您好,您到服务器SSH终端中执行下面命令(非面板终端)修复面板
删除之前无法使用的面板环境
mv/www/s ...

执行第二条命令报错了,现在执行 bt命令也报错了T_T
页: [1]
查看完整版本: 【待反馈】面板绑定域名并开启SSL访问,登录信息中的IP信