compasspanda 发表于 2025-6-4 09:27:52

【已解答】SuperVisord启动不了紧急求助 研究好几天了

为了能快速了解并处理您的问题,请提供以下基础信息:面板、插件版本:
面板8.0.1
   插件3.0.5
系统版本:
Linux version 3.10.0-1127.19.1.el7.x86_64 (mockbuild@kbuilder.bsys.centos.org) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-39) (GCC) )
问题描述:
我安装守护进程就报启动失败 重启 启动都办法启动 运行日志也没有 我截图发贴报错超字数??服务日志报错-- Logs begin at Thu 2025-01-16 11:05:01 CST, end at Wed 2025-06-04 09:27:16 CST. --Apr 08 15:50:42 iZ0jo73g84hj7g4lz24gumZ systemd: Cannot add dependency job for unit supervisord.service, ignoring: Unit is masked.
-- Reboot --
Apr 08 15:51:21 iZ0jo73g84hj7g4lz24gumZ systemd: Cannot add dependency job for unit supervisord.service, ignoring: Unit is masked.
相关截图(日志、错误):

阿珂 发表于 2025-6-4 12:12:53

上面提示supervisord服务被系统屏蔽了
使用下面命令解除看看
systemctl unmask supervisord
systemctl enable supervisord
systemctl start supervisord

compasspanda 发表于 2025-6-4 16:11:36

阿珂 发表于 2025-6-4 12:12
上面提示supervisord服务被系统屏蔽了
使用下面命令解除看看

还是提醒错误

阿珂 发表于 2025-6-5 10:22:47

错误提示什么

compasspanda 发表于 2025-6-6 09:05:30

compasspanda 发表于 2025-6-4 16:11
还是提醒错误

我写出现的错误命令回来提醒我有不良的内容 一直提交不enablesupervisord的时候会提醒Fail ed to executeoperation:Cannotsendaftertransportendpointshutdown;

compasspanda 发表于 2025-6-6 09:06:07

阿珂 发表于 2025-6-5 10:22
错误提示什么

# systemctl enable supervisord
Fail ed to execute operation: Cannot send after transport endpoint shutdown
# systemctl start supervisord
Fail ed to start supervisord.service: Unit is masked.

阿珂 发表于 2025-6-6 15:21:19

还是屏蔽的
systemctl unmask supervisord
执行这个命令提示什么

compasspanda 发表于 2025-6-7 14:42:50

阿珂 发表于 2025-6-6 15:21
还是屏蔽的
systemctl unmask supervisord
执行这个命令提示什么

什么也没提醒 应该这个命令执行是成功的

compasspanda 发表于 2025-6-7 17:54:28

阿珂 发表于 2025-6-6 15:21
还是屏蔽的
systemctl unmask supervisord
执行这个命令提示什么

麻烦帮忙排查下呢

compasspanda 发表于 2025-6-9 16:36:25

阿珂 发表于 2025-6-6 15:21
还是屏蔽的
systemctl unmask supervisord
执行这个命令提示什么

麻烦帮忙看看呢

阿珂 发表于 2025-6-10 10:54:50

systemctl list-unit-files | grep supervisord
检查服务是否存在
是否使用了安全软件,将防护关闭,重装一下
页: [1]
查看完整版本: 【已解答】SuperVisord启动不了紧急求助 研究好几天了