建议宝塔初始化MYSQL localhost的密码和127.0.0.1 的密......
[*]默认配置的“陷阱”:宝塔面板默认会给 MySQL 创建 'root'@'localhost' 和 'root'@'127.0.0.1' 这两个账户。这为密码不一致埋下了伏笔。
[*]常见的操作导致不同步:最典型的情况是,如果你通过 SSH 终端手动 用 mysqladmin 或 UPDATE 语句修改了密码,你修改的可能只是 'root'@'localhost' 这一个账户的密码。而宝塔面板的“数据库”管理界面,可能检测或连接时用的是 'root'@'127.0.0.1' 这个账户。这就会导致面板里记录的密码,和你刚修改的密码不是同一个账户的,从而报错。这与其说是 BUG,不如说是一个容易踩的“坑”。
[*]账户权限的混淆:有时用户会无意中修改或删除了某个 host 的账户权限,导致面板功能异常。比如面板备份功能依赖特定 host 的权限,一旦不一致就会失败
这个是AI的回答,这个宝塔面板能不能优化一下,这个害死人啊
localhost和127.0.0.1 我一直认为通用的,localhost的密码和127.0.0.1 的密码 是一样的
建议宝塔初始化MYSQL localhost的密码和127.0.0.1 的密.一样..
您好,非常感谢反馈和支持,这边已经记录您的问题。
如果您还有更多问题和疑虑,您可以通过客服咨询宝塔面板相关问题:https://docs.bt.cn/wechat-service
操作方式:复制链接在微信打开,即可在线咨询客服。 感觉不安全。127.0.0.1
页:
[1]