当前位置:论坛首页 > Linux面板 > 求助

数据库客户端版本过低

发表在 Linux面板2018-1-13 22:42 [复制链接] 5 205

网站原本是在阿里云虚拟主机上的,数据库版本是 5.1.73
现在转移到 ECS,通过宝塔装了 MySQL 5.7 。然后直接将老网站 5.1.73 的数据库导入进来。
目前「服务器版本」是5.7,「客户端版本」是5.1,为什么两边的版本不一样?有没有办法能针对客户端版本进行升级?

mysql_upgrade 试过了,无效。

phpMyAdmin后台截图

phpMyAdmin后台截图

使用道具 举报 只看该作者 回复

准内测组成员

发表于 2018-1-14 17:08:43 | 显示全部楼层
在sql文件里改一下声明就可以了,我以前博客就是这样弄得
使用道具 举报 回复 支持 反对
发表于 2018-1-15 16:34:28 | 显示全部楼层
mingxue 发表于 2018-1-14 17:08
在sql文件里改一下声明就可以了,我以前博客就是这样弄得

声明怎么添加?
网上有没教程,可以告诉我能搜到的关键词或链接吗?
使用道具 举报 回复 支持 反对

准内测组成员

发表于 2018-1-15 20:29:04 | 显示全部楼层
rockben 发表于 2018-1-15 16:34
声明怎么添加?
网上有没教程,可以告诉我能搜到的关键词或链接吗?

我忘了搜什么了,你直接导入他就会有提示错误的,然后你百度那个错误就行了,我之前就是这样解决的
使用道具 举报 回复 支持 反对
发表于 2018-1-16 10:38:07 | 显示全部楼层
mingxue 发表于 2018-1-15 20:29
我忘了搜什么了,你直接导入他就会有提示错误的,然后你百度那个错误就行了,我之前就是这样解决的 ...

我没提示出错。。。使用也是正常的,直到用phpadmin才发现两个的版本不对
使用道具 举报 回复 支持 反对
发表于 2018-1-16 12:23:19 | 显示全部楼层
mingxue 发表于 2018-1-15 20:29
我忘了搜什么了,你直接导入他就会有提示错误的,然后你百度那个错误就行了,我之前就是这样解决的 ...

问题解决了。
是我傻了,没有重装网站,还是连接之前的数据库。。。所以版本一直有问题
使用道具 举报 回复 支持 反对
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

【求助贴,请有以下信息】

①错误提示截图;

②操作系统版本;

③环境信息;

信息详细,秒速帮你处理

上班时间:周一至周六 9:00~18:30

如果紧急,官网后台提交付费工单解决

腾讯云代理商优惠

小黑屋|BT.cn  

© 2014-2018 bt.cn All Rights Reserved.   Powered by Discuz! X3.2

宝塔论坛正在使用宝塔Linux面板维护管理并由尊云(zun.com)提供云服务器支持

快速回复 返回顶部 返回列表