当前位置:论坛首页 > BUG提交 > Linux面板

【已解答】Nginx访问php文件都是变成下载Index文件的问题

发表在 BUG提交2021-8-11 20:49 [复制链接] 4 470

下面是我的Nginx配置:

server
{
    listen 80;
    server_name central.3456wan.vip;
    index index.php index.html index.htm default.php default.htm default.html;
    root /central/www/public;

    #SSL-START SSL相关配置,请勿删除或修改下一行带注释的404规则
    #error_page 404/404.html;
    #SSL-END

    #ERROR-PAGE-START  错误页配置,可以注释、删除或修改
    #error_page 404 /404.html;
    #error_page 502 /502.html;
    #ERROR-PAGE-END

    #PHP-INFO-START  PHP引用配置,可以注释或修改
    include enable-php-74.conf;
    #PHP-INFO-END

    #REWRITE-START URL重写规则引用,修改后将导致面板设置的伪静态规则失效
    include /www/server/panel/vhost/rewrite/central.3456wan.vip.conf;
    #REWRITE-END

    #禁止访问的文件或目录
    location ~ ^/(\.user.ini|\.htaccess|\.git|\.svn|\.project|LICENSE|README.md)
    {
        fastcgi_pass 127.0.0.1:9000;#php-fpm的默认端口是9000
        fastcgi_index index.php;
        fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
        include fastcgi_params;
    }

        location ~ [^/]\.php(/|$)
        {
            # comment try_files $uri =404; to enable pathinfo
            try_files $uri =404;
            fastcgi_pass  unix:/tmp/php-cgi.sock;
            fastcgi_index index.php;
            include fastcgi.conf;
            #include pathinfo.conf;
        }   

    #一键申请SSL证书验证目录相关设置
    location ~ \.well-known{
        allow all;
    }

    location ~ .*\.(gif|jpg|jpeg|png|bmp|swf)$
    {
        expires      30d;
        error_log /dev/null;
        access_log /dev/null;
    }

    location ~ .*\.(js|css)?$
    {
        expires      12h;
        error_log /dev/null;
        access_log /dev/null;
    }
    access_log  /www/wwwlogs/central.3456wan.vip.log;
    error_log  /www/wwwlogs/central.3456wan.vip.error.log;
}

我安装了俩个PHP的版本,一个是 7.2,一个是5.6,但是在切换项目的PHP版本的时候总是会默认把PHP版本修改为 纯静态,点击保存是修改成功了,但是刷新之后又是 纯静态

使用道具 举报 只看该作者 回复
发表于 2021-8-12 09:58:47 | 显示全部楼层
宝塔用户_mqhcwn 发表于 2021-8-12 09:48
如果PHP版本有2个的话,那么在修改项目PHP版本的时候会自动默认为是 纯静态,无论修改什么版本,点击确定 ...

您好,您的项目如果有使用多个PHP的话,建议独立开来。
您的这里的代码
include enable-php-74.conf;

Nginx的规则是从上到下进行匹配,只要匹配到了一个,下面的规则优先级低的话,不再加载下面的。
另外我们处理php-fpm 的时候默认是使用的socket Unix套接字,
fastcgi_pass 127.0.0.1:9000;#php-fpm的默认端口是9000

这里的配置:
fastcgi_pass  unix:/tmp/php-cgi.sock;

/tmp/php-cgi.sock 这个文件是否存在,你到这个目录下查看下。还有你的伪静态,截图看下




使用道具 举报 回复 支持 1 反对 0
发表于 2021-8-11 21:00:30 | 显示全部楼层
宝塔版本:7.6.0
浏览器:Google
系统:CentOS 7.7.1908
使用道具 举报 回复 支持 反对
发表于 2021-8-11 23:50:50 | 显示全部楼层
您好,访问php文件自动下载,要么是自己设置了纯静态,要么自己写的代码中断了php解析。
关于您说的php版本设置不成功问题,麻烦截图面板首页环境看看 QQ截图20210811235001.png


使用道具 举报 回复 支持 反对
发表于 2021-8-12 09:48:35 | 显示全部楼层
运维阿宏 发表于 2021-8-11 23:50
您好,访问php文件自动下载,要么是自己设置了纯静态,要么自己写的代码中断了php解析。
关于您说的php版本 ...

如果PHP版本有2个的话,那么在修改项目PHP版本的时候会自动默认为是 纯静态,无论修改什么版本,点击确定之后都会默认自动变成 纯静态
snipaste20210812_094342.png

Nginx访问自动变成下载

Nginx访问自动变成下载
使用道具 举报 回复 支持 反对
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表