徐先森丶 发表于 2023-10-17 14:41:21

【已完成】openssl 报错

为了能快速了解并处理您的问题,请提供以下基础信息:面板、插件版本:专业版8.0.2
系统版本:centos7.9
问题描述:如图 就是莫名在日志里面报错 说openssl 无法加载 ,但是我PHP8.0的phpinfo显示是有openssl 扩展的
相关截图(日志、错误):phpinfo截图如下错误日志如下PHP Warning:PHP Startup: Unable to load dynamic library 'openssl' (tried: /www/server/php/80/lib/php/extensions/no-debug-non-zts-20200930/openssl (/www/server/php/80/lib/php/extensions/no-debug-non-zts-20200930/openssl: cannot open shared object file: No such file or directory), /www/server/php/80/lib/php/extensions/no-debug-non-zts-20200930/openssl.so (/www/server/php/80/lib/php/extensions/no-debug-non-zts-20200930/openssl.so: cannot open shared object file: No such file or directory)) in Unknown on line 0

谢花郎 发表于 2023-10-17 14:44:02

您好,您是否有在PHP配置文件将下面截图内的注释去掉了呢?面板内的PHP在安装时已经是默认内置到PHP内安装了的
不需要在PHP配置文件内取消注释呢

徐先森丶 发表于 2023-10-17 15:05:20

谢花郎 发表于 2023-10-17 14:44
您好,您是否有在PHP配置文件将下面截图内的注释去掉了呢?面板内的PHP在安装时已经是默认内置到PHP内安装 ...

已经去掉了

徐先森丶 发表于 2023-10-17 15:06:34

谢花郎 发表于 2023-10-17 14:44
您好,您是否有在PHP配置文件将下面截图内的注释去掉了呢?面板内的PHP在安装时已经是默认内置到PHP内安装 ...

是需要把注释加上吗?如果取消掉 会有什么影响吗

谢花郎 发表于 2023-10-17 15:09:27

徐先森丶 发表于 2023-10-17 15:06
是需要把注释加上吗?如果取消掉 会有什么影响吗

就会提示错误,添加回去然后重启PHP即可。PHP内是已经使用了Openssl扩展模块了,不需要再到配置文件上动配置文件呢。

徐先森丶 发表于 2023-10-17 15:13:34

谢花郎 发表于 2023-10-17 15:09
就会提示错误,添加回去然后重启PHP即可。PHP内是已经使用了Openssl扩展模块了,不需要再到配置文件上动 ...

我把注释加上了并重启了PHP但是我的进程守护 还是会报这个错误

谢花郎 发表于 2023-10-17 15:17:16

徐先森丶 发表于 2023-10-17 15:13
我把注释加上了并重启了PHP但是我的进程守护 还是会报这个错误
PHP是已经引用了openssl模块了,如果您程序还是提示错误,您可以检查您当前所执行的PHP代码
这个需要您自己检查,PHP内的openssl模块我们是确保开启了的

马尔克 发表于 2023-11-16 22:22:20

我也遇到了同样的问题,就是把注释openssl放开后报同样的错误,重新注释过后重启了php和Nginx后还是报这个错误,请问最后是怎么解决的呢?

马尔克 发表于 2023-11-16 22:56:55

马尔克 发表于 2023-11-16 22:22
我也遇到了同样的问题,就是把注释openssl放开后报同样的错误,重新注释过后重启了php和Nginx后还是报这个 ...

问题解决了,宝塔这个是个BUG,PHP管理面板的配置文件引用的是 /www/server/php/74/etc/php.ini 但php --ini给的加载配置文件却是 /www/server/php/74/etc/php-cli.ini,修改了在面板修改配置文件放开了openssl扩展项,但是重新注释的时候php-cli.ini没有跟着变更回来,所以导致一直都报错!在控制台直接用vim修改php-cli.ini后重启PHP就恢复正常了,我晕。。。。。

phpinfo 显示的配置文件


php --ini 显示加载的配置文件


大炮运维V587 发表于 2023-11-28 12:18:06

马尔克 发表于 2023-11-16 22:56
问题解决了,宝塔这个是个BUG,PHP管理面板的配置文件引用的是 /www/server/php/74/etc/php.ini 但php -- ...

您好,如果您一直使用的是面板而不是bash命令行的话,是没有问题的。

宝塔用户_ttfomt 发表于 2025-6-19 16:51:04

马尔克 发表于 2023-11-16 22:56
问题解决了,宝塔这个是个BUG,PHP管理面板的配置文件引用的是 /www/server/php/74/etc/php.ini 但php -- ...

大神 你怎么解决的
页: [1]
查看完整版本: 【已完成】openssl 报错