当前位置:论坛首页 > Linux面板 > 求助

请问打开面板ssl的时候失败,提示这个怎么办?

发表在 Linux面板2017-12-23 22:23 [复制链接] 7 3398

打开ssl的时候提示开启失败,无法自动安装pyopenssl组建,但是不会手动安装该怎么办呢?
1.jpg

使用道具 举报 只看该作者 回复
发表于 2017-12-25 00:12:20 | 显示全部楼层
进入ssh执行那条命令
使用道具 举报 回复 支持 反对
发表于 2017-12-25 10:00:27 | 显示全部楼层
河妖 发表于 2017-12-25 00:12
进入ssh执行那条命令

那条命令具体是什么呢?
使用道具 举报 回复 支持 反对
发表于 2017-12-25 10:03:36 | 显示全部楼层
pip install pyOpenSSL
使用道具 举报 回复 支持 反对
发表于 2017-12-25 16:45:59 | 显示全部楼层
河妖 发表于 2017-12-25 10:03
pip install pyOpenSSL

手动输入了命令安装,还是不行,提示下面这个。
QQ截图20171225164242.jpg
使用道具 举报 回复 支持 反对
发表于 2017-12-25 16:48:26 | 显示全部楼层
河妖 发表于 2017-12-25 10:03
pip install pyOpenSSL

系统版本是CentOS 6.5
使用道具 举报 回复 支持 反对
发表于 2018-1-22 08:09:43 | 显示全部楼层
pip install --upgrade pip
执行这个命令,把pip升级到新版就可以啦
使用道具 举报 回复 支持 反对
发表于 2018-7-25 11:22:08 | 显示全部楼层
sailing 发表于 2018-1-22 08:09
pip install --upgrade pip
执行这个命令,把pip升级到新版就可以啦

[root@iZwz9ccq9xttkyhx3cqrkwZ ~]# pip install --upgrade pip
k, DEPRECATION: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of pip will drop support for Python 2.6
/usr/lib/python2.6/site-packages/pip/_vendor/urllib3/util/ssl_.py:339: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/e ... e.html#ssl-warnings
  SNIMissingWarning
/usr/lib/python2.6/site-packages/pip/_vendor/urllib3/util/ssl_.py:137: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/e ... e.html#ssl-warnings
  InsecurePlatformWarning
Collecting pip
  Downloading https://pypi.doubanio.com/packag ... y2.py3-none-any.whl (1.3MB)
    100% |████████████████████████████████| 1.3MB 33.4MB/s
pip requires Python '>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*' but the running Python is 2.6.6
   You are using pip version 9.0.3, however version 18.0 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
使用道具 举报 回复 支持 反对
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表