当前位置:论坛首页 > Linux面板 > Linux面板教程

从5.9平滑升级到6.x

发表在 Linux面板2018-11-21 16:15   [复制链接] 202 167922

兼容的操作系统:Centos7.x
升级方式:使用命令升级



可能发生的问题和解决方案:

     问题1: 抱歉, Centos6.x无法通过此脚本升级到6.0!
     解决方案:Centos6.x的Python版本过低,不再被宝塔6.x兼容,建议您升级到Centos7,如果您对Centos比较熟悉也可以尝试安装Python3.4作为默认Python,但处理不好的话可能导致您的yum管理器无法正常使用

     问题2:检测到您的系统中安装有云锁,请先将云锁的[系统加固]功能关闭,再重新执行升级命令
     解决方案:将云锁的[系统加固]功能关闭,然后重新执行升级命令


     问题3:抱歉, 本升级脚本仅支持Centos7..
     解决方案:我们目前对Ubuntu/Debian等操作系统下的升级脚本还没有足够的信心,请关注我们后续推出的升级脚本


     问题3:升级后无法访问面板
     解决方案:
                    1、重新执行升级命令,若发现有报错,请截图在此贴回贴,或在QQ群联系技术人员求助
                    2、若重复执行升级命令依然无法访问面板,请执行以下命令,并将显示结果截图发给我们
  1. tail -n 50 /www/server/panel/logs/error.log
复制代码

    问题4:升级后面板能正常登录,但无法获取软件列表   
    解决方案:造成这个问题是因为网络原因,导致升级过程不完整,请尝试重新执行升级命令,若一直无法得到解决,请联系我们的技术人员为您手动升级


    问题5:升级后原来的计划任务无法编辑
    解决方案:我们在6.0对计划任务模块进行了重写,不再兼容5.9的计划任务,但不影响原来计划任务的执行,仅是无法编辑,如果在意,请删除旧的计划任务后重新添加

    问题6:我原来是专业版,专业版的升级命令在哪里?
    解决方案:专业版和免费版使用一样的升级命令,升级成功登录面板后自动升级为专业版

    问题7:如何退回5.9?
    解决方案:卸载所有插件,然后使用5.9的安装命令重装

    问题8: 升级后某些插件无法使用
    解决方案: 卸载无法使用的插件,重新安装


    升级命令:
    注意:
    1、Centos6请勿执行此升级命令

    2、升级过程耗时较长且可能会受网络因素影响导致升级失败
    3、如果升级后无法正常启动面板,请重新执行升级命令
    4、升级有一定的风险,生产环境请谨慎升级
  1. curl -sSO http://download.bt.cn/install/update_to_6.sh && bash update_to_6.sh
复制代码







使用道具 举报 只看该作者 回复
发表于 2018-11-22 12:19:17 | 显示全部楼层
Centos6的,暂时不想冒险升级6,就用5.9的没事吧
使用道具 举报 回复 支持 2 反对 1
发表于 2018-11-22 09:25:51 | 显示全部楼层
aooicom 发表于 2018-11-21 23:49
升级失败了,面板打不开了,升级2次都是打不开。这是错误日志,麻烦工程师帮忙看看。

您好,已针对您的情况做了针对处理,请尝试重新执行升级命令,谢谢
使用道具 举报 回复 支持 2 反对 0
发表于 2018-11-22 14:27:44 | 显示全部楼层
Always 发表于 2018-11-22 13:20
升级成功后,提升再升级PY。
无报错。

感谢,我测试下
使用道具 举报 回复 支持 1 反对 0
发表于 2018-11-22 12:31:46 | 显示全部楼层
通过脚本升级,没有问题,但是重启后,ssh不好使,仔细检查,发现有一个进程rsync,监听了22端口,将此进程kill掉再重启sshd服务就好使了。rsync这个是什么进程?同步进程?在未升级前没有发现端口冲突的情况啊?
使用道具 举报 回复 支持 1 反对 0
发表于 2021-9-24 12:34:23 | 显示全部楼层
本帖最后由 cainethk 于 2021-9-24 12:45 编辑

出现了问题4:升级后面板能正常登录,但无法获取软件列表   ,请求帮助一下,谢谢
使用道具 举报 回复 支持 反对
发表于 2021-7-12 10:58:56 | 显示全部楼层
宝塔版本是5.9,想购买专业版本的,必须要升级才能购买吗?
使用道具 举报 回复 支持 反对
发表于 2021-6-21 11:36:42 | 显示全部楼层
请问不升级会有什么问题吗?
使用道具 举报 回复 支持 反对
发表于 2021-6-1 17:56:01 | 显示全部楼层
在升级中遇到以下问题提示:
update_to_6.sh: line 115: wget: command not found
du: cannot access ‘/www/pyenv.tar.gz’: No such file or directory
update_to_6.sh: line 117: [: -lt: unary operator expected
Install python env...
chmod: cannot access ‘/www/server/panel/pyenv/bin’: No such file or directory
=================================================
ERROR: Install python env fielded.
使用道具 举报 回复 支持 反对
发表于 2020-11-16 09:25:49 | 显示全部楼层
一键部署,提示网站不存在。
使用道具 举报 回复 支持 反对
发表于 2020-9-20 22:39:54 | 显示全部楼层
QQ图片20200920223910.png 再次升级是这样的还是打不开
使用道具 举报 回复 支持 反对
发表于 2020-9-20 22:22:52 | 显示全部楼层
QQ图片20200920222053.png 升级后打不开面板
使用道具 举报 回复 支持 反对
发表于 2020-9-20 22:21:57 | 显示全部楼层
QQ图片20200920222053.png 升级完打不开面板了
使用道具 举报 回复 支持 反对
发表于 2020-9-5 18:27:46 | 显示全部楼层
升级失败,无法联系服务器, CentOS 6.8 系统!
使用道具 举报 回复 支持 反对
发表于 2020-9-4 16:59:27 | 显示全部楼层
宝塔面板5.9平滑升级后打开失败,然后重新安装还是打不开。系统版本centos7.4。
使用道具 举报 回复 支持 反对
发表于 2020-8-26 17:14:11 | 显示全部楼层
使用道具 举报 回复 支持 反对
发表于 2020-8-26 16:36:33 | 显示全部楼层
各位大神,升级成功但是面板无法打不开。
重新装了几次都不行,麻烦各位大神看看怎么处理哇。 升级失败.png




使用道具 举报 回复 支持 反对
发表于 2020-8-26 16:35:57 | 显示全部楼层
本帖最后由 aimeko 于 2020-8-26 16:37 编辑

各位大神,升级成功但是面板无法打不开。
重新装了几次都不行,麻烦各位大神看看怎么处理,感谢感谢。





使用道具 举报 回复 支持 反对
发表于 2020-8-25 16:30:31 | 显示全部楼层
我现在是5.9的LIUNX版本,想升级到最新版本,但是怕出问题,现在平滑升级会出问题么。求大神回答!
使用道具 举报 回复 支持 反对
发表于 2020-8-3 16:16:29 | 显示全部楼层
河妖 发表于 2020-8-3 15:09
好的 咋解决的 重复安装?

对的,重新安装一下就好了
使用道具 举报 回复 支持 反对
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表