当前位置:论坛首页 > Linux面板 > 求助

【已回应】关闭php5.6然后开启php7.0,网站404了

发表在 Linux面板2018-11-27 19:40 [复制链接] 5 1589

本帖最后由 大炮运维V587 于 2018-11-28 09:36 编辑

我之前是先安装的php5.6,一直运行着网站没问题,今天又安装了php7.0,结果我关闭了5.6,启用7.0后网站就404not fund了,服务器重启过,php重启过,nginx重启过,能重启的都重启了,如果是重启服务器,那么重启后进入宝塔就发现php5.6和php7.0都是开启的。
为什么会404NOT FUND!
使用道具 举报 只看该作者 回复
发表于 2018-11-28 11:18:04 | 显示全部楼层
51digit 发表于 2018-11-28 09:58
听您的意思是php7压根就不能用?生7只为安装mediawiki1.31,无奈小7不能用,最终只安装了给1.27版本。
不 ...

并没有说不能用,我的意思是既然做站点首先要考虑稳定。既然是插件不能支持只能更新到高版本了。祝顺商祺。
使用道具 举报 回复 支持 2 反对 0
发表于 2018-11-27 23:04:45 | 显示全部楼层
本帖最后由 痞子哥 于 2019-5-7 14:28 编辑

如果要切换PHP版本的话  在站点设置  PHP版本里  改成对应的版本。
看你描述的过程,你之前网站用的PHP5.6,安装PHP7之后,网站没有切换PHP版本又把PHP5.6关闭了。


使用道具 举报 回复 支持 反对
发表于 2018-11-28 09:36:45 | 显示全部楼层
我想问下,PHP5.6运行着没有问题,为啥要换成php7的呢?我特别想知道您的心理想法和操作习惯
使用道具 举报 回复 支持 反对
发表于 2018-11-28 09:58:19 | 显示全部楼层
大炮运维V587 发表于 2018-11-28 09:36
我想问下,PHP5.6运行着没有问题,为啥要换成php7的呢?我特别想知道您的心理想法和操作习惯 ...

听您的意思是php7压根就不能用?生7只为安装mediawiki1.31,无奈小7不能用,最终只安装了给1.27版本。
不过外国人的程序,实在不敢苟同,太丑太难用了,还是考虑下国内的hdwiki吧。
使用道具 举报 回复 支持 反对
发表于 2018-11-28 10:00:32 | 显示全部楼层
1499605410sfdq 发表于 2018-11-27 23:04
如果要切换PHP版本的话  在站点设置  PHP版本里  改成对应的版本。
看你描述的过程,你之前网站用的PHP5.6 ...

你的回答大大的有用,谢谢了,我就这里没有改。
使用道具 举报 回复 支持 反对
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表