当前位置:论坛首页 > Linux面板 > Linux面板教程

关于部分服务器无法获取Let's Encrypt的解决方法

发表在 Linux面板2017-5-20 18:41 [复制链接] 24 11926

近期发现有部分服务器在安装面板时,没有成功下载certbot-auto,导致无法正常获取Let's Encrypt证书,现提供手动下载安装的方法

卸载可能损坏的epel源(若确定epel源没问题,可跳过):
  1. yum remove epel-release -y
复制代码



下载脚本:
  1. wget -O /www/server/panel/certbot-auto http://download.bt.cn/install/certbot-auto.init -T 5
复制代码


安装依赖:
安装过程可能耗时比较长,大概需要5-10分钟,请耐心等待!
  1. chmod +x /www/server/panel/certbot-auto && /www/server/panel/certbot-auto -n
复制代码

提示以下内容,说明安装成功
  1. Saving debug log to /var/log/letsencrypt/letsencrypt.log
  2. Missing command line flags. For non-interactive execution, you will need to specify a plugin on the command line.  Run with '--help plugins' to see a list of options, and see https://eff.org/letsencrypt-plugins for more detail on what the plugins do and how to use them.
复制代码

使用道具 举报 只看该作者 回复
发表于 2017-5-20 20:40:26 | 显示全部楼层
……/server/php/70/bin/php                             
php-7.0.16-1.el6.x86_64 has missing requires of xml
rpc                                                
Could not install OS dependencies. Aborting bootstr
ap!                                                
[root@static ~]#
好像没成功
使用道具 举报 回复 支持 反对
发表于 2017-5-20 21:14:56 | 显示全部楼层
php-5.4.45-1.el6.x86_64 has missing requires of xmlrpc
php-7.0.16-1.el6.x86_64 is a duplicate with php-5.4.45-1.el6.x86_64
php-7.0.16-1.el6.x86_64 has missing requires of /home/a/rpmbuild/BUILDROOT/php-7.0.16-1.el6.x86_64/www/server/php/70/bin/php
php-7.0.16-1.el6.x86_64 has missing requires of xmlrpc
Could not install OS dependencies. Aborting bootstrap!
使用道具 举报 回复 支持 反对
发表于 2017-5-22 00:18:42 | 显示全部楼层
无用
使用道具 举报 回复
发表于 2017-5-22 13:44:09 | 显示全部楼层
没好用~~~~~~~~~~~~~~~~~~
使用道具 举报 回复
发表于 2017-5-22 14:06:58 | 显示全部楼层
Could not install OS dependencies. Aborting bootstrap!
使用道具 举报 回复 支持 反对
发表于 2017-5-22 18:36:57 | 显示全部楼层
xiaoyunet 发表于 2017-5-22 14:06
Could not install OS dependencies. Aborting bootstrap!

那就没办法,因网络原图安装依赖不成功
使用道具 举报 回复 支持 反对
发表于 2017-5-23 09:38:51 | 显示全部楼层
良哥 发表于 2017-5-22 18:36
那就没办法,因网络原图安装依赖不成功

能单独安装依赖嘛?
使用道具 举报 回复 支持 反对
发表于 2017-5-23 09:56:09 | 显示全部楼层
良哥 发表于 2017-5-22 18:36
那就没办法,因网络原图安装依赖不成功

如果全部重新安装,包括系统。会不会好用?
使用道具 举报 回复 支持 反对
发表于 2017-5-23 10:21:01 | 显示全部楼层
xiaoyunet 发表于 2017-5-23 09:56
如果全部重新安装,包括系统。会不会好用?

不用重装系统,你百度一下,网站有很多Let's Encrypt的安装教程,只要Let's Encrypt手动安装成功就可以
使用道具 举报 回复 支持 反对
发表于 2017-5-23 16:14:27 | 显示全部楼层

Could not install OS dependencies. Aborting bootstrap!

无法安装操作系统依赖项。中止引导!  发表于 2017-5-23 18:16
使用道具 举报 回复 支持 反对
发表于 2017-5-24 11:49:29 | 显示全部楼层
[root@iZ2ze8d3jgsseswg83vkbzZ wyshn]# chmod +x /www/server/panel/certbot-auto && /www/server/panel/certbot-auto -n
Upgrading certbot-auto 0.12.0 to 0.14.1...
Replacing certbot-auto...
/root/.local/share/letsencrypt/lib/python2.6/site-packages/cryptography/__init__.py:26: DeprecationWarning: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of cryptography will drop support for Python 2.6
  DeprecationWarning
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Missing command line flags. For non-interactive execution, you will need to specify a plugin on the command line.  Run with '--help plugins' to see a list of options, and see https://eff.org/letsencrypt-plugins for more detail on what the plugins do and how to use them.


按照这个提示安装不了,怎么办呀?
使用道具 举报 回复 支持 反对
发表于 2017-5-24 12:15:07 | 显示全部楼层
wyshn 发表于 2017-5-24 11:49
[root@iZ2ze8d3jgsseswg83vkbzZ wyshn]# chmod +x /www/server/panel/certbot-auto && /www/server/panel/c ...

你这个已经安装成功了啊,可以正常使用了,若获取证书失败,请检查你的站点是否有设置301,所有域名是否解析正确,也看看具体返回的错误信息。
使用道具 举报 回复 支持 反对
发表于 2017-5-24 12:28:11 | 显示全部楼层
良哥 发表于 2017-5-24 12:15
你这个已经安装成功了啊,可以正常使用了,若获取证书失败,请检查你的站点是否有设置301,所有域名是否 ...

错误类型: connection
详情: DNS problem: query timed out looking up A for


提示这个,我没有设301,域名解析也是对的。还需要查一下什么呀?
使用道具 举报 回复 支持 反对
发表于 2017-5-24 12:40:43 | 显示全部楼层
wyshn 发表于 2017-5-24 12:28
错误类型: connection
详情: DNS problem: query timed out looking up A for

验证服务器返回DNS超时了,建议你换个DNS解析域名,如dns.com,dnspod

8块已转账,请哥喝杯红牛,谢谢。  发表于 2017-5-24 13:28
使用道具 举报 回复 支持 反对
12下一页
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表