当前位置:论坛首页 > Linux面板 > 求助

【已解答】同一配置服务器的redis 不支持6.x

发表在 Linux面板2022-1-26 17:13 [复制链接] 8 173

同一配置服务器的redis 不支持6.x  默认安装 5.x 版本了,另一个服务器就安装得上Redis  6.x 就没问题
2.PNG
使用道具 举报 只看该作者 回复
发表于 2022-1-26 17:28:46 | 显示全部楼层
您好,您服务器内执行下面命令看下是什么系统版本以及内核版本

  1. cat /etc/redhat-release | grep ' 6.' | grep -iE 'centos|Red Hat'
  2. uname -r
复制代码
使用道具 举报 回复 支持 反对
发表于 2022-1-26 18:47:05 | 显示全部楼层
谢花郎 发表于 2022-1-26 17:28
您好,您服务器内执行下面命令看下是什么系统版本以及内核版本

[root@VM-12-6-centos ~]# cat /etc/redhat-release | grep ' 6.' | grep -iE 'centos|Red Hat'
[root@VM-12-6-centos ~]# uname -r
5.4.173-1.el7.elrepo.x86_64
[root@VM-12-6-centos ~]#
使用道具 举报 回复 支持 反对
发表于 2022-1-27 10:04:47 | 显示全部楼层
ylwzbk 发表于 2022-1-26 18:47
[root@VM-12-6-centos ~]# cat /etc/redhat-release | grep ' 6.' | grep -iE 'centos|Red Hat'
[root@VM ...

麻烦您再执行下面命令检查下GCC版本,如GCC版本过低是无法安装redis的

  1. gcc -v 2>&1|grep "gcc version"|awk '{printf("%d",$3)}'
复制代码
使用道具 举报 回复 支持 反对
发表于 2022-1-27 10:07:47 | 显示全部楼层
谢花郎 发表于 2022-1-27 10:04
麻烦您再执行下面命令检查下GCC版本,如GCC版本过低是无法安装redis的

[root@VM-16-10-centos ~]# gcc -v 2>&1|grep "gcc version"|awk '{printf("%d",$3)}'

4
使用道具 举报 回复 支持 反对
发表于 2022-1-27 10:12:50 | 显示全部楼层
ylwzbk 发表于 2022-1-27 10:07
[root@VM-16-10-centos ~]# gcc -v 2>&1|grep "gcc version"|awk '{printf("%d",$3)}'

4

您那边试下安装这两个组件,然后再试试安装吧,如果安装不上就没办法了。

  1. yum install centos-release-scl-rh -y
  2. yum install devtoolset-7-gcc devtoolset-7-gcc-c++ -y
复制代码
使用道具 举报 回复 支持 反对
发表于 2022-1-27 10:18:18 | 显示全部楼层
谢花郎 发表于 2022-1-27 10:12
您那边试下安装这两个组件,然后再试试安装吧,如果安装不上就没办法了。

...

不行咯  我试试手动编译看看
使用道具 举报 回复 支持 反对
发表于 2022-1-29 16:24:13 | 显示全部楼层
问题解决 yum源的问题 修改回了默认的就正常了
使用道具 举报 回复 支持 反对
发表于 2022-2-26 10:56:30 | 显示全部楼层
ylwzbk 发表于 2022-1-29 16:24
问题解决 yum源的问题 修改回了默认的就正常了

此帖子问题已经解决。yum源问题导致。
使用道具 举报 回复 支持 反对
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表