当前位置:论坛首页 > Linux面板 > 求助

手动更新5.6.0面板后七牛备份脚本出错

发表在 Linux面板2018-2-13 18:22 [复制链接] 0 330

本帖最后由 神代綺凜 于 2018-2-13 18:25 编辑

系统 Debian8 x64,宝塔 5.6.0

之前我的所有使用5.5.0面板的机子都出现了无法自动更新,提示连接服务器失败!”的现象,于是我只能手动用命令更新

后来发现有一台机子就出现了七牛备份错误的现象,并且点开七牛云储存1.5的设置界面,F12的console会提示500错误
  1. jquery-1.10.2.min.js:5 GET http://xxxxxxx/plugin?action=a&name=qiniu&s=GetConfig 500 (Internal Server Error)
  2. send @ jquery-1.10.2.min.js:5
  3. ajax @ jquery-1.10.2.min.js:5
  4. x.(anonymous function) @ jquery-1.10.2.min.js:5
  5. (anonymous) @ VM1268:12
  6. c @ jquery-1.10.2.min.js:3
  7. add @ jquery-1.10.2.min.js:3
  8. ready @ jquery-1.10.2.min.js:3
  9. init @ jquery-1.10.2.min.js:3
  10. x @ jquery-1.10.2.min.js:3
  11. (anonymous) @ VM1268:11
  12. (anonymous) @ soft.js?date=20180124:1712
  13. setTimeout (async)
  14. (anonymous) @ soft.js?date=20180124:1708
  15. c @ jquery-1.10.2.min.js:3
  16. fireWith @ jquery-1.10.2.min.js:3
  17. k @ jquery-1.10.2.min.js:5
  18. r @ jquery-1.10.2.min.js:5
  19. XMLHttpRequest.send (async)
  20. send @ jquery-1.10.2.min.js:5
  21. ajax @ jquery-1.10.2.min.js:5
  22. x.(anonymous function) @ jquery-1.10.2.min.js:5
  23. PluginMan @ soft.js?date=20180124:1687
  24. onclick @ soft:1
复制代码
看计划任务执行日志有以下Python错误
  1. Traceback (most recent call last):
  2.   File "/www/server/panel/plugin/qiniu/qiniu_main.py", line 13, in
  3.     from qiniu import Auth
  4.   File "/usr/local/lib/python2.7/dist-packages/qiniu/__init__.py", line 14, in
  5.     from .auth import Auth, QiniuMacAuth
  6.   File "/usr/local/lib/python2.7/dist-packages/qiniu/auth.py", line 7, in
  7.     from requests.auth import AuthBase
  8.   File "/usr/lib/python2.7/dist-packages/requests/__init__.py", line 68, in
  9.     _attach_namespace(urllib3, 'requests.packages')
  10.   File "/usr/lib/python2.7/dist-packages/requests/__init__.py", line 63, in _attach_namespace
  11.     module = __import__(name)
  12.   File "/usr/lib/python2.7/dist-packages/urllib3/contrib/pyopenssl.py", line 55, in
  13.     import OpenSSL.SSL
  14.   File "/usr/lib/python2.7/dist-packages/OpenSSL/__init__.py", line 8, in
  15.     from OpenSSL import rand, crypto, SSL
  16.   File "/usr/lib/python2.7/dist-packages/OpenSSL/rand.py", line 11, in
  17.     from OpenSSL._util import (
  18.   File "/usr/lib/python2.7/dist-packages/OpenSSL/_util.py", line 4, in
  19.     binding = Binding()
  20.   File "/usr/lib/python2.7/dist-packages/cryptography/hazmat/bindings/openssl/binding.py", line 89, in __init__
  21.     self._ensure_ffi_initialized()
  22.   File "/usr/lib/python2.7/dist-packages/cryptography/hazmat/bindings/openssl/binding.py", line 113, in _ensure_ffi_initialized
  23.     libraries=libraries,
  24.   File "/usr/lib/python2.7/dist-packages/cryptography/hazmat/bindings/utils.py", line 80, in build_ffi
  25.     extra_link_args=extra_link_args,
  26.   File "/usr/lib/python2.7/dist-packages/cffi/api.py", line 340, in verify
  27.     lib = self.verifier.load_library()
  28.   File "/usr/lib/python2.7/dist-packages/cffi/verifier.py", line 75, in load_library
  29.     return self._load_library()
  30.   File "/usr/lib/python2.7/dist-packages/cffi/verifier.py", line 151, in _load_library
  31.     return self._vengine.load_library()
  32.   File "/usr/lib/python2.7/dist-packages/cffi/vengine_cpy.py", line 149, in load_library
  33.     raise ffiplatform.VerificationError(error)
  34. cffi.ffiplatform.VerificationError: importing '/usr/lib/python2.7/dist-packages/cryptography/_Cryptography_cffi_813c10e0x7adb75f8.x86_64-linux-gnu.so': /usr/lib/python2.7/dist-packages/cryptography/_Cryptography_cffi_813c10e0x7adb75f8.x86_64-linux-gnu.so: symbol EC_GFp_nistp521_method, version OPENSSL_1.0.1 not defined in file libcrypto.so.1.0.0 with link time reference
复制代码
修复面板无效

顺便问一下就算手动更新到5.6.0,如果检查更新还是会提示连接服务器失败!”是怎么回事……
使用道具 举报 只看该作者 回复
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

【求助贴,请有以下信息】

①错误提示截图;

②操作系统版本;

③环境信息;

信息详细,秒速帮你处理

上班时间:周一至周六 9:00~18:30

如果紧急,官网后台提交付费工单解决

小黑屋|BT.cn  

© 2014-2018 bt.cn All Rights Reserved.   Powered by Discuz! X3.2

宝塔论坛正在使用宝塔Linux面板维护管理并由尊云(zun.com)提供云服务器支持

快速回复 返回顶部 返回列表