当前位置:论坛首页 > Linux面板 > 求助

【已解决】node为啥没有18版本的

发表在 Linux面板2023-5-25 19:10 [复制链接] 7 2226

本帖最后由 堡塔运维小林 于 2023-5-27 00:01 编辑

为了能快速了解并处理您的问题,请提供以下基础信息:
面板、插件版本:

宝塔7.9.10  ,Node.js版本管理器 1.9
系统版本:

Cenos7.9   
问题描述:

node 安装列表没有 18版本的,换了3个源,都找不到
相关截图(日志、错误):

微信图片_20230525190759.png
使用道具 举报 只看该作者 回复
发表于 2023-5-25 19:15:21 | 显示全部楼层
官方肯定是有18版本的,现在主页都推荐用18的。烦请宝塔官方团队解决一下,谢谢
未命名1685013249.png
使用道具 举报 回复 支持 反对
发表于 2023-5-25 20:09:06 | 显示全部楼层
您好,插件里的版本是直接从registry源获取的,若没有的话您可点击更新版本列表再看看 下载 (1).png
使用道具 举报 回复 支持 反对
发表于 2023-5-26 07:26:22 | 显示全部楼层
堡塔运维盏尽 发表于 2023-5-25 20:09
您好,插件里的版本是直接从registry源获取的,若没有的话您可点击更新版本列表再看看
...

3个数据源都刷新了,最高就到17.9.1
未命名1685057139.png
使用道具 举报 回复 支持 反对
发表于 2023-5-26 07:40:48 | 显示全部楼层
我好像发现了问题所在,centos7.9 刷新只到17.9版本, centos9 刷新版本列表,可以到20.2
使用道具 举报 回复 支持 反对
发表于 2023-5-26 10:32:21 | 显示全部楼层
您好,根据您服务器系统内的GCC版本环境获取的,如果您服务器系统内的GCC环境版本过低是不会推荐最高版本的。
如果是安装最高的node版本会提示GLIBC系统之类错误的,node是依赖于服务器内的GCC环境运行的。
使用道具 举报 回复 支持 反对
发表于 2023-5-26 21:43:06 | 显示全部楼层
我安装了centos9   解决了该问题
使用道具 举报 回复 支持 反对
发表于 2024-4-7 15:03:08 | 显示全部楼层
谢花郎 发表于 2023-5-26 10:32
您好,根据您服务器系统内的GCC版本环境获取的,如果您服务器系统内的GCC环境版本过低是不会推荐最高版本的 ...

更新了GCC版本以后,能不能在centOS7.9上18以上的nodejs
使用道具 举报 回复 支持 反对
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

企业版年付运维跟进群

普通问题处理

论坛响应时间:72小时

问题处理方式:排队(仅解答)

工作时间:白班:9:00 - 18:00

紧急问题处理

论坛响应时间:10分钟

问题处理方式:1对1处理(优先)

工作时间:白班:9:00 - 18:00

工作时间:晚班:18:00 - 24:00

立即付费处理
快速回复 返回顶部 返回列表