当前位置:论坛首页 > Linux面板 > 求助

【已回应】swoole安装的问题

发表在 Linux面板2018-12-3 20:01 [复制链接] 3 1791

本帖最后由 大炮运维V587 于 2018-12-4 09:49 编辑

求助求助求助求助
在宝塔面板的PHP上安装了swoole扩展,phpinfo上也有显示这个上扩展是开启的,然在终端执行命令php -m确不显示。调用时也提示找不着这个swoole的类。。面板安装swoole会默认在php配置文件上增加这个扩展,为什么
使用道具 举报 只看该作者 回复
发表于 2018-12-4 09:49:15 | 显示全部楼层
您重载下php试试,一般在PHPinfo中显示的就已经开启了
使用道具 举报 回复 支持 反对
发表于 2018-12-4 10:04:21 | 显示全部楼层
大炮运维V587 发表于 2018-12-4 09:49
您重载下php试试,一般在PHPinfo中显示的就已经开启了

已经显示了,重启linux还是不行。
https://www.bt.cn/bbs/forum.php? ... mp;highlight=swoole
我看这个帖子教程上说要开启开启通讯进程服务,可是我看我的根目录下面根本没有这个些目录
使用道具 举报 回复 支持 反对
发表于 2018-12-4 10:55:40 | 显示全部楼层
liuliang 发表于 2018-12-4 10:04
已经显示了,重启linux还是不行。
https://www.bt.cn/bbs/forum.php?mod=viewthread&tid=10171&highlight ...

调用时报了下面这样一个错误

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/swoole.so' - /usr/lib64/php/modules/swoole.so: cannot open shared object file: No such file or directory in Unknown on line 0
使用道具 举报 回复 支持 反对
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

紧急运维服务

响应时间:3分钟

问题处理方式:宝塔专家1对1服务

工作时间:工作日:9:00 - 18:30

宝塔专业团队为您解决服务器疑难问题

点击联系技术分析

工作时间:09:00至18:30

快速回复 返回顶部 返回列表