当前位置:论坛首页 > Linux面板 > 讨论

【已回应】Ubuntu 18.04 编译安装 PHP 7.3 出错,--with-openssl不...

发表在 Linux面板2019-8-13 03:33 [复制链接] 3 313

本帖最后由 谢花郎 于 2019-8-14 09:42 编辑

Ubuntu 18.04 LTS
kernel 4.19.20
宝塔Linux面板6.9.30

问题:
编译安装PHP 7.3 出现
configure: error: Cannot find OpenSSL's libraries

尝试解决:
--with-openssl不用加路径,./configure 通过

Add:
libiconv也要编译更新到libiconv-1.16,不然会找不到
ln -s /usr/local/lib/libiconv.so /usr/lib
ln -s /usr/local/lib/libiconv.so.2 /usr/lib/libiconv.so.2

引用:
github.com/mongodb/mongo-php-driver/issues/138#issuecomment-223020111
使用道具 举报 只看该作者 回复
发表于 2019-8-13 18:22:34 | 显示全部楼层
没有做过任何修改就可以安装 phpubu.png Ubuntu.png
使用道具 举报 回复 支持 反对
发表于 2019-8-13 18:24:18 | 显示全部楼层
没修改过就可以
使用道具 举报 回复 支持 反对
发表于 2019-8-14 15:12:00 | 显示全部楼层
好像 php 编译在 Ubuntu 上面的问题挺多的,我遇到过 19.04 不能编译 php7.2,原因是 freetype 这个 lib 没有找到?
但是 apt-get 啥的都表示已经安装了相关 lib,自己也去对应目录找了下都是有文件,网上找到的全都是 apt-get install libfreetype6……后来嘛,直接放弃了
使用道具 举报 回复 支持 反对
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表