当前位置:论坛首页 > Linux面板 > 求助

【已解答】CentOS 7.5.1804(Py3.7.9) BT7.6 安装PHP7.4失败

发表在 Linux面板2021-7-23 18:03 [复制链接] 9 285

发表于 2021-7-24 09:48:38 | 显示全部楼层
谢花郎 发表于 2021-7-24 09:46
能提供一下机器登录信息吗?我帮你看看。

好的,麻烦了
使用道具 举报 回复 支持 反对
发表于 2021-7-24 09:46:57 | 显示全部楼层
宝塔用户_oolvwy 发表于 2021-7-24 09:45
您好,这是执行的结果,是有东西,但是宝塔那边php还是装不上

能提供一下机器登录信息吗?我帮你看看。
使用道具 举报 回复 支持 反对
发表于 2021-7-24 09:45:57 | 显示全部楼层
谢花郎 发表于 2021-7-24 09:41
您好,服务器内依次执行下面命令看看

您好,这是执行的结果,是有东西,但是宝塔那边php还是装不上
3.png
使用道具 举报 回复 支持 反对
发表于 2021-7-24 09:43:23 | 显示全部楼层
大炮运维V587 发表于 2021-7-24 09:25
重新安装下curl、cmake

您好,这是我再执行的结果,请问是不是配置文件里需要改什么镜像之类的呢?我这边初次进入宝塔页面时是选择了编译安装,安装完之后发现一个都没装上,随后去软件商店点了快速安装
1.png
2.png
使用道具 举报 回复 支持 反对
发表于 2021-7-24 09:41:00 | 显示全部楼层

您好,服务器内依次执行下面命令看看

  1. rpm -qa | grep cmake
复制代码
使用道具 举报 回复 支持 反对
发表于 2021-7-24 09:25:37 | 显示全部楼层
  1. yum install curl curl-devel libcurl libcurl-devel cmake -y
复制代码

重新安装下curl、cmake
使用道具 举报 回复 支持 反对
发表于 2021-7-23 19:36:10 | 显示全部楼层
大炮运维V587 发表于 2021-7-23 18:09
您好,您到服务器SSH中执行下

然后重新安装下php7.4 您服务器上缺少cmake这个依赖 ...

您好,这个命令我执行完之后是这样,再去安装还是同一个报错,请问这种情况怎么办
STIS8SCR{LSN9{4P4QH)T1R.png
使用道具 举报 回复 支持 反对
发表于 2021-7-23 18:09:04 | 显示全部楼层

您好,您到服务器SSH中执行下
  1. yum install cmake -y
复制代码

然后重新安装下php7.4 您服务器上缺少cmake这个依赖
使用道具 举报 回复 支持 反对
发表于 2021-7-23 18:05:52 | 显示全部楼层
这是日志的截图
T71Y(8]$736(UCMJ0YNPJQA.png
使用道具 举报 回复 支持 反对
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表