当前位置:论坛首页 > Linux面板 > 求助

【已解答】php5.6启动不了

发表在 Linux面板2021-10-13 16:07 [复制链接] 14 71

装好面板php启动不了  出现如下错误
微信截图_20211013160345.png
微信截图_20211013160410.png
使用道具 举报 只看该作者 回复
发表于 2021-10-13 16:15:26 | 显示全部楼层
@大炮运维V587
使用道具 举报 回复 支持 反对
发表于 2021-10-13 16:52:48 | 显示全部楼层

截图看下执行日志过程,如果没有记录了的话,卸载重新使用编译模式安装下PHP看下
1.png
使用道具 举报 回复 支持 反对
发表于 2021-10-13 17:32:09 | 显示全部楼层
谢花郎 发表于 2021-10-13 16:52
截图看下执行日志过程,如果没有记录了的话,卸载重新使用编译模式安装下PHP看下 ...

编译模式安装失败
微信截图_20211013172958.png
使用道具 举报 回复 支持 反对
发表于 2021-10-13 18:08:53 | 显示全部楼层

您执行下这个命令看下有无libmcrypt组件

  1. rpm -qa | grep libmcrypt
复制代码
使用道具 举报 回复 支持 反对
发表于 2021-10-13 18:13:14 | 显示全部楼层

到服务器客户端的SSH中(非面板终端)执行
  1. yum update -y
复制代码

更新下系统,然后执行
  1. yum install libmcrypt -y
复制代码

安装下这个依赖
使用道具 举报 回复 支持 反对
发表于 2021-10-13 18:13:40 | 显示全部楼层
还不行的话,私信发ToDesk或者向日葵远程连接码
使用道具 举报 回复 支持 反对
发表于 2021-10-14 12:29:55 | 显示全部楼层
大炮运维V587 发表于 2021-10-13 18:13
还不行的话,私信发ToDesk或者向日葵远程连接码

更新了  还是安装失败
使用道具 举报 回复 支持 反对
发表于 2021-10-14 13:09:02 | 显示全部楼层
大炮运维V587 发表于 2021-10-13 18:13
还不行的话,私信发ToDesk或者向日葵远程连接码

更新系统导致nginx启动不了
使用道具 举报 回复 支持 反对
发表于 2021-10-14 14:21:51 | 显示全部楼层
大炮运维V587 发表于 2021-10-13 18:13
到服务器客户端的SSH中(非面板终端)执行

更新下系统,然后执行

更新后就成这样了  现在网站都用不了啦
微信截图_20211014141943.png
使用道具 举报 回复 支持 反对
发表于 2021-10-14 19:28:39 | 显示全部楼层
宝塔用户_llikoe 发表于 2021-10-14 14:21
更新后就成这样了  现在网站都用不了啦

您好,您的Nginx的提示是有端口正在被占用着,您Nginx是无法启动还是什么?您有修改过其他 应用的端口吗?
  1. netstat -lntup|grep 80
  2. netstat -lntup|grep 443
复制代码
使用道具 举报 回复 支持 反对
发表于 2021-10-14 22:15:16 | 显示全部楼层
大炮运维V587 发表于 2021-10-14 19:28
您好,您的Nginx的提示是有端口正在被占用着,您Nginx是无法启动还是什么?您有修改过其他 应用的端口吗? ...

搞得只能重装系统了  现在已经重装系统搞好了  系统升级不能轻易尝试  
使用道具 举报 回复 支持 反对
发表于 2021-10-14 22:23:19 | 显示全部楼层
宝塔用户_llikoe 发表于 2021-10-14 22:15
搞得只能重装系统了  现在已经重装系统搞好了  系统升级不能轻易尝试

端口被占用为什么要用重新安装操作系统?卸载重新安装服务我能理解,为什么要重装系统 ??
使用道具 举报 回复 支持 反对
发表于 2021-10-15 10:20:42 | 显示全部楼层
大炮运维V587 发表于 2021-10-14 22:23
端口被占用为什么要用重新安装操作系统?卸载重新安装服务我能理解,为什么要重装系统 ?? ...

执行 yum update -y  这条命令后   很多应用都打不开了  我尝试恢复镜像也不能解决问题  所以我重装系统了
使用道具 举报 回复 支持 反对
发表于 2021-10-15 10:26:05 | 显示全部楼层
宝塔用户_llikoe 发表于 2021-10-15 10:20
执行 yum update -y  这条命令后   很多应用都打不开了  我尝试恢复镜像也不能解决问题  所以我重装系统了 ...

yum update -y
给你发这个命令的原因看到你的系统是CentOS7.2版本的,执行后是升级到CentOS 最新版本,你的php错误提示是缺少libcrypto.so.1.0.0 这个动态共享库,更新系统会重新建立缺少的动态库,但是这个不会影响你的其他应用无法打开的。
使用道具 举报 回复 支持 反对
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表