当前位置:论坛首页 > Linux面板 > 求助

【已解决】Rspamd一直提示未安装

发表在 Linux面板2022-1-15 17:12 [复制链接] 4 44

点修复没有,翻了别的帖子,找到了大佬提供的代码,但是在使用时出现错误: 无法验证 rspamd.com 的由 “/C=US/O=Let's Encrypt/CN=R3” 颁发的证书:

QQ截图20220115170740.jpg


  1. wget -O /etc/yum.repos.d/rspamd.repo https://rspamd.com/rpm-stable/centos-7/rspamd.repo
  2. rpm --import https://rspamd.com/rpm-stable/gpg.key
  3. yum install rspamd -y
复制代码


运行wget的时候错误: 无法验证 rspamd.com 的由 “/C=US/O=Let's Encrypt/CN=R3” 颁发的证书:
1.jpg


使用道具 举报 只看该作者 回复
发表于 2022-1-15 17:42:28 | 显示全部楼层
根据他的提示,加上那个参数下载安装一下;

  1. 根证书过期的问题
  2. mv /etc/pki/tls/certs/ca-bundle.crt /etc/pki/tls/certs/ca-bundle.crt_backup
  3. mkdir -p /etc/pki/tls/certs
  4. wget -O /etc/pki/tls/certs/ca-bundle.crt https://curl.se/ca/cacert.pem
  5. chmod 444 /etc/pki/tls/certs/ca-bundle.crt
复制代码

根证书问题可以按照这个处理一下
使用道具 举报 回复 支持 反对
发表于 2022-1-15 18:04:04 | 显示全部楼层
堡塔安全赤井秀一 发表于 2022-1-15 17:42
根据他的提示,加上那个参数下载安装一下;

1.jpg 2.jpg
第一步成功了下载了,第二行代码有出了问题
使用道具 举报 回复 支持 反对
发表于 2022-1-15 18:11:18 | 显示全部楼层
宝塔用户_nlejea 发表于 2022-1-15 18:04
第一步成功了下载了,第二行代码有出了问题

先处理好服务器内https问题吧,我上面发了命令
使用道具 举报 回复 支持 反对
发表于 2022-1-15 18:15:13 | 显示全部楼层
堡塔安全赤井秀一 发表于 2022-1-15 17:42
根据他的提示,加上那个参数下载安装一下;

谢谢大佬,以及解决了,根证书那里没整好。
重新弄了一下,现在可以了
非常感谢
使用道具 举报 回复 支持 反对
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表