当前位置:论坛首页 > Linux面板 > 求助

【待反馈】负载均衡网站配置ssl后,页面无法识别https

发表在 Linux面板2022-3-24 13:54 [复制链接] 5 3645

原站点未开启负载均衡,部署ssl证书访问一切正常。开启负载均衡后,主站点设置了ssl,子节点也设置了ssl,但未设置强制ssl。访问时网址会显示https,但页面有些加载不了https.报错如图:
有能解决的吗?
使用道具 举报 只看该作者 回复
发表于 2022-3-24 14:28:54 | 显示全部楼层
非https.png
您好,您看下您网站内容中的部分url是不是写固定的http链接了?
使用道具 举报 回复 支持 反对
发表于 2022-3-24 14:41:14 | 显示全部楼层
大炮运维V587 发表于 2022-3-24 14:28
您好,您看下您网站内容中的部分url是不是写固定的http链接了?

没有呢,知道取消负载均衡,https就正常了,就不会报错了。

只要开了负载均衡https就不正常。

都是配置了https的。
使用道具 举报 回复 支持 反对
发表于 2022-3-24 15:25:20 | 显示全部楼层
宝塔用户_uqsvek 发表于 2022-3-24 14:41
没有呢,知道取消负载均衡,https就正常了,就不会报错了。

只要开了负载均衡https就不正常。

OK,稍等我排查下是哪里的问题
使用道具 举报 回复 支持 反对
发表于 2022-3-24 15:40:07 | 显示全部楼层
大炮运维V587 发表于 2022-3-24 15:25
OK,稍等我排查下是哪里的问题

好的,我这边是用的宝塔的一键部署的微擎系统,开的负载均衡
使用道具 举报 回复 支持 反对
发表于 2022-3-25 16:49:43 | 显示全部楼层
宝塔用户_uqsvek 发表于 2022-3-24 15:40
好的,我这边是用的宝塔的一键部署的微擎系统,开的负载均衡

这个问题正在排查中,您稍等
使用道具 举报 回复 支持 反对
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

紧急运维服务

响应时间:3分钟

问题处理方式:宝塔专家1对1服务

工作时间:工作日:9:00 - 18:30

宝塔专业团队为您解决服务器疑难问题

点击联系技术分析

工作时间:09:00至18:30

快速回复 返回顶部 返回列表