堡塔724运维节,企业版724元/年,永久授权最高立减6000元,仅限7.24日当天查看活动
当前位置:论坛首页 > Linux面板 > Linux面板教程

【持续更新】华为欧拉系统装不上软件FAQ

发表在 Linux面板2022-6-29 22:46 [复制链接] 21 3121

本贴只更新处理欧拉系统问题,有问题直接留言,留言格式如下
服务器商家:(华为、物理机、其他)
产品:(ECS、其他、不知道就不填)
系统:(可以执行命令然后截图发,命令:cat /etc/os-release)
遇到了什么问题:

下面是持续更新的临时解决方法:
1.华为云服务器欧拉2.5系统,安装不上php(nginx也可以试试),可以执行下面的命令,然后重新尝试安装
  1. yum remove -y libwebp libwebp-devel gd gd-devel
  2. wget https://vault.centos.org/centos/8/AppStream/x86_64/os/Packages/libwebp-devel-1.0.0-5.el8.x86_64.rpm
  3. wget https://vault.centos.org/centos/8/AppStream/x86_64/os/Packages/gd-devel-2.2.5-7.el8.x86_64.rpm
  4. wget https://vault.centos.org/centos/8/AppStream/x86_64/os/Packages/gd-2.2.5-7.el8.x86_64.rpm
  5. wget https://vault.centos.org/centos/8/AppStream/x86_64/os/Packages/libwebp-1.0.0-5.el8.x86_64.rpm
  6. rpm -ivh libwebp-1.0.0-5.el8.x86_64.rpm --nodeps
  7. rpm -ivh libwebp-devel-1.0.0-5.el8.x86_64.rpm --nodeps
  8. rpm -ivh gd-2.2.5-7.el8.x86_64.rpm --nodeps
  9. rpm -ivh gd-devel-2.2.5-7.el8.x86_64.rpm --nodeps
复制代码


2.华为云服务器欧拉2.0系统,安装不上php(nginx也可以试试),可以执行下面的命令,然后重新尝试安装
  1. yum remove -y libwebp libwebp-devel gd gd-devel
  2. wget http://mirror.centos.org/centos/7/os/x86_64/Packages/gd-2.0.35-26.el7.x86_64.rpm
  3. wget http://mirror.centos.org/centos/7/os/x86_64/Packages/gd-devel-2.0.35-26.el7.x86_64.rpm
  4. wget http://mirror.centos.org/centos/7/os/x86_64/Packages/libwebp-0.3.0-7.el7.x86_64.rpm
  5. wget http://mirror.centos.org/centos/7/os/x86_64/Packages/libwebp-devel-0.3.0-7.el7.x86_64.rpm
  6. rpm -ivh gd-2.0.35-26.el7.x86_64.rpm --nodeps
  7. rpm -ivh gd-devel-2.0.35-26.el7.x86_64.rpm --nodeps
  8. rpm -ivh libwebp-0.3.0-7.el7.x86_64.rpm --nodeps
  9. rpm -ivh libwebp-devel-0.3.0-7.el7.x86_64.rpm --nodeps
复制代码

使用道具 举报 只看该作者 回复
发表于 2022-7-12 12:13:10 | 显示全部楼层
有人用这个系统做站吗?

问题已解决蓝易云:hwww.tsyvps.com/free.html 暑期云服务器大采购  发表于 2022-7-21 12:04
使用道具 举报 回复 支持 反对
发表于 2022-7-18 17:06:09 | 显示全部楼层
还真有人买华为么?

我们都是键盘支持
使用道具 举报 回复 支持 反对
发表于 2022-7-21 08:54:15 | 显示全部楼层
已经尝试在物理机 Dell R630 服务器上安装 欧拉OS系统,持续更新,在使用欧拉OS+宝塔面板的一些经验。
使用道具 举报 回复 支持 反对
发表于 2022-7-25 21:56:47 | 显示全部楼层
欧拉 通过面板安装php 无法安装7.1版本,尝试安装可7.3和5.6可以安装。
使用道具 举报 回复 支持 反对
发表于 2022-8-4 09:22:36 | 显示全部楼层
@堡塔安全赤井秀一
使用道具 举报 回复 支持 反对
发表于 2022-8-6 09:14:48 | 显示全部楼层
kissab5 发表于 2022-7-25 21:56
欧拉 通过面板安装php 无法安装7.1版本,尝试安装可7.3和5.6可以安装。

重新安装一下,然后将消息盒子的执行日志截图发出来看看
执行日志.png
使用道具 举报 回复 支持 反对
发表于 2022-8-7 09:13:28 | 显示全部楼层
堡塔安全赤井秀一 发表于 2022-8-6 09:14
重新安装一下,然后将消息盒子的执行日志截图发出来看看

QQ截图20220807091102.png
使用道具 举报 回复 支持 反对
发表于 2022-8-8 21:25:01 | 显示全部楼层
没用过这个
使用道具 举报 回复 支持 反对
发表于 2022-8-11 10:06:14 | 显示全部楼层
正准备把centos替换为openeuler;关注一下先
使用道具 举报 回复 支持 反对
发表于 2022-8-13 22:28:48 | 显示全部楼层
服务器商家:物理机[img]https://gitee.com/zhangda2/zhangda/raw/master/1.png[/img]
使用道具 举报 回复 支持 反对
发表于 2022-8-13 22:29:58 | 显示全部楼层
服务器商家:[img]https://gitee.com/zhangda2/zhangda/raw/master/1.png[/img]物理机
使用道具 举报 回复 支持 反对
发表于 2022-8-17 11:04:26 | 显示全部楼层
支持華為!支持華為!!支持華為!!!




























雖然我還在用centOS
使用道具 举报 回复 支持 反对
发表于 2022-8-26 13:58:01 | 显示全部楼层
ZF要求CENTOS全换Euler系统了,安装OpenEuler 22后发现 系统启动项管理插件无法使用 20220826
01.png

02.png


使用道具 举报 回复 支持 反对
发表于 2022-9-1 17:30:02 | 显示全部楼层
今天我也安装了Huawei Cloud EulerOS 2.0 果然PHP7.4和Nginx无法启动, Nginx报错:/www/server/nginx/sbin/nginx: error while loading shared libraries: libgd.so.2: cannot open shared object file: No such file or directory
PHP7.4报错:
警告消息:
/bin/sh: line 1: /etc/init.d/php-fpm-74: No such file or directory



使用道具 举报 回复 支持 反对
12下一页
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表