当前位置:论坛首页 > Linux面板 > 求助

php 5.2.17扩展问题

发表在 Linux面板2017-12-20 17:06 [复制链接] 3 1606

PHP Warning: PHP Startup: Unable to load dynamic library '/www/server/php/52/lib/php/extensions/no-debug-non-zts-20060613/mysqli.so' - /www/server/php/52/lib/php/extensions/no-debug-non-zts-20060613/mysqli.so: undefined symbol: client_errors in Unknown on line 0   

php 5.2.17版本启动的时候的警告,运行程序访问数据库的时候页面显示404

使用道具 举报 只看该作者 回复
发表于 2017-12-20 17:48:28 | 显示全部楼层
用编译方式重装php5.2 另外你的mysql是什么版本的呢
使用道具 举报 回复 支持 反对
发表于 2017-12-21 10:04:35 | 显示全部楼层
河妖 发表于 2017-12-20 17:48
用编译方式重装php5.2 另外你的mysql是什么版本的呢

pi/cgi/fpm/zlog.lo sapi/cgi/fpm/fpm_trace.lo sapi/cgi/fpm/fpm_trace_ptrace.lo main/internal_functions.lo -lcrypt -lz -lcrypt -lrt -lmysqlclient -lmhash -lmcrypt -lltdl -liconv -lfreetype -lpng -lz -ljpeg -lssl -lcrypto -lcurl -lz -lssl -lcrypto -lrt -lresolv -lm -ldl -lnsl -lrt -lxml2 -lz -lm -lcurl -lxml2 -lz -lm -lmysqlclient -lm -lrt -ldl -lmysqlclient -lm -lrt -ldl -lxml2 -lz -lm -lxml2 -lz -lm -lcrypt -lxml2 -lz -lm -lxml2 -lz -lm -lxml2 -lz -lm -lxml2 -lz -lm -lcrypt /www/server/php/52/src/libevent/libevent.a -lnsl -lrt -lresolv -lxml2 -lz -lm  -o sapi/cgi/php-cgi
/usr/bin/ld: warning: libssl.so.10, needed by /usr/local/curl/lib/libcurl.so, may conflict with libssl.so.1.0.0
/usr/bin/ld: warning: libssl.so.10, needed by /usr/local/curl/lib/libcurl.so, may conflict with libssl.so.1.0.0
/usr/bin/ld: warning: libssl.so.10, needed by /usr/local/curl/lib/libcurl.so, may conflict with libssl.so.1.0.0
/usr/bin/ld: warning: libcrypto.so.10, needed by /usr/local/curl/lib/libcurl.so, may conflict with libcrypto.so.1.0.0
/usr/bin/ld: warning: libcrypto.so.10, needed by /usr/local/curl/lib/libcurl.so, may conflict with libcrypto.so.1.0.0
/usr/bin/ld: warning: libcrypto.so.10, needed by /usr/local/curl/lib/libcurl.so, may conflict with libcrypto.so.1.0.0
ext/mysqli/mysqli.o: In function `php_local_infile_error':
/www/server/php/52/src/ext/mysqli/mysqli.c:1175: undefined reference to `client_errors'
ext/mysqli/mysqli.o: In function `php_local_infile_read':
/www/server/php/52/src/ext/mysqli/mysqli.c:1113: undefined reference to `client_errors'
ext/mysqli/mysqli.o: In function `php_local_infile_init':
/www/server/php/52/src/ext/mysqli/mysqli.c:1064: undefined reference to `client_errors'
collect2: ld returned 1 exit status
make: *** [sapi/cgi/php-cgi] Error 1
========================================================
ERROR: php-5.2 installation failed.

编译安装失败   MySQL是5.7的
使用道具 举报 回复 支持 反对
发表于 2017-12-21 10:05:20 | 显示全部楼层
wushunpeng 发表于 2017-12-21 10:04
pi/cgi/fpm/zlog.lo sapi/cgi/fpm/fpm_trace.lo sapi/cgi/fpm/fpm_trace_ptrace.lo main/internal_functi ...

.。。。。如果是mysql5.7的话是无法编译安装上php5.2的
使用道具 举报 回复 支持 反对
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表