堡塔724运维节,企业版724元/年,永久授权最高立减6000元,仅限7.24日当天查看活动
当前位置:论坛首页 > Linux面板 > 建议

【已解答】是否考虑支持arm(aarch64)版本linux

发表在 Linux面板4 天前 [复制链接] 6 71

现有万能安装脚本是否支持 arm(aarch64)版本linux

if [ -f /usr/bin/curl ];then curl -sSO https://download.bt.cn/install/install_panel.sh;else wget -O install_panel.sh https://download.bt.cn/install/install_panel.sh;fi;bash install_panel.sh ed8484bec
使用道具 举报 只看该作者 回复
发表于 4 天前 | 显示全部楼层
我自己测试过 Ubuntu 和 CentOS Stream 8,在 aarch64 架构下宝塔都是能完美运行,但是部分软件或者插件可能会不正常。其他不正常是因为宝塔本来就对这个系统不太兼容,比如 Deepin。
官方测试结果的列表中,大部分 aarch64 都能正常运行。
https://docs.qq.com/sheet/DUm54VUtyTVNlc21H
使用道具 举报 回复 支持 反对
发表于 4 天前 | 显示全部楼层
你可以列举出需要优先兼容的软件或插件,可以优先兼容,aarch64只要软件能编译的上去,面板上就能兼容正常;一般优先考虑红帽系的
使用道具 举报 回复 支持 反对
发表于 4 天前 | 显示全部楼层
本帖最后由 firstfx 于 2022-8-6 18:11 编辑

目前是 oracle linux 9
我尝试了一下  mysql 8 无法安装建议优先适配运行环境
使用道具 举报 回复 支持 反对
发表于 4 天前 | 显示全部楼层
堡塔安全木兰 发表于 2022-8-6 14:37
你可以列举出需要优先兼容的软件或插件,可以优先兼容,aarch64只要软件能编译的上去,面板上就能兼容正常 ...

红帽系 oracle linux 9
建议优先适配运行环境
使用道具 举报 回复 支持 反对
发表于 4 天前 | 显示全部楼层
firstfx 发表于 2022-8-6 18:12
红帽系 oracle linux 9
建议优先适配运行环境

什么原因需要使用最新的9?建议还oracle linux8,目前兼容性较好;默认走的是编译模式,如果系统自己编译不上说明oracle linux9本身不兼容mysql8,需要单独看看有没有集成的rpm包
使用道具 举报 回复 支持 反对
发表于 前天 01:21 | 显示全部楼层
堡塔安全木兰 发表于 2022-8-6 18:14
什么原因需要使用最新的9?建议还oracle linux8,目前兼容性较好;默认走的是编译模式,如果系统自己编译 ...

硬件为 华为 鲲鹏920 新版本 兼容性测试
使用道具 举报 回复 支持 反对
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表