堡塔724运维节,企业版724元/年,永久授权最高立减6000元,仅限7.24日当天查看活动
当前位置:论坛首页 > Linux面板 > 求助

【已解答】nginx启动不了

发表在 Linux面板4 天前 [复制链接] 3 58

Screenshot_20220806_162359_com.huawei.browser.jpg 我那个下了nginx openrensty,启动不了,这是怎么了
使用道具 举报 只看该作者 回复
发表于 4 天前 | 显示全部楼层
什么系统架构?armv7还是s390x?
常见的x86_64和aarch64是可以安装openrenstry的,这个是报兼容性错误了
使用道具 举报 回复 支持 反对
发表于 4 天前 | 显示全部楼层
堡塔安全木兰 发表于 2022-8-6 16:33
什么系统架构?armv7还是s390x?
常见的x86_64和aarch64是可以安装openrenstry的,这个是报兼容性错误了 ...

![](https://s3.bmp.ovh/imgs/2022/08/06/0eefd98ca8ab8b57.jpg)
使用道具 举报 回复 支持 反对
发表于 4 天前 | 显示全部楼层
强仔 发表于 2022-8-6 16:39
![](https://s3.bmp.ovh/imgs/2022/08/06/0eefd98ca8ab8b57.jpg)

报错原因是:系统缺少luajit组件,导致nginx使用异常;
解决方法:卸载nginx防火墙/nginx免费防火墙,网站加速(这些插件没装的话可忽略此步骤)卸载当前版本的nginx,使用编译模式安装一遍nginx1.22试一下,编译安装会自动安装luajit组件;
装好nginx后重装前面卸载的那几个插件即可正常使用。

openrensty想要试的话也试一下编译安装
使用道具 举报 回复 支持 反对
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表