堡塔724运维节,企业版724元/年,永久授权最高立减6000元,仅限7.24日当天查看活动

宝塔Linux面板安装教程 - 2022年7月14日更新 - 7.9.3正式版

置顶 精华 发表在 Linux面板 2018-11-16 18:33   [复制链接] 527 5337656





安装要求:
内存:512M以上,推荐768M以上(纯面板约占系统60M内存)
硬盘:300M以上可用硬盘空间(纯面板约占20M磁盘空间)
系统:CentOS 7.1+ (Ubuntu16.04+.、Debian9.0+),确保是干净的操作系统没有安装过其它环境带的Apache/Nginx/php/MySQL/pgsql/gitlab/java已有环境不可安装
架构:x86_64(主流服务器均是此架构),ARM不完整兼容(面板环境安装慢,部分软件可能安装不上)

宝塔Linux面板7.9.3版本是基于Centos/Debian/Ubuntu开发的,为了最好的兼容性,请使用以上系统
Centos 8官方已经停止支持、如需安装建议更换Centos7系统或升级至Centos 8 Stream系统安装宝塔
系统兼容性顺序:
Centos7.x > Debian10 > Ubuntu 20.04 > Cenots 8 stream > Ubuntu 18.04 > 其它系统
系统兼容支持状况详情:https://docs.qq.com/sheet/DUm54VUtyTVNlc21H

以下主机商必看(开端口教程,不开不能用):
阿里云:https://www.bt.cn/bbs/thread-2897-1-1.html  阿里云2折起
华为云:https://www.bt.cn/bbs/thread-3923-1-1.html  
华为云1折起

推荐先安装 堡塔SSH客户端 (免费/简单/中文/多屏)

Linux面板7.9.3安装命令:(推荐使用价格厚道,高性能v4的尊云zun.comCEPH云服务器安装)使用SSH 连接工具(查看使用方法),挂载磁盘后(查看),根据系统执行框内命令开始安装(大约2分钟完成面板安装)
Centos 8官方已经停止支持、请更换Centos7系统或Centos 8 Stream系统安装宝塔

Centos安装命令:
  1. yum install -y wget && wget -O install.sh http://download.bt.cn/install/install_6.0.sh && sh install.sh
复制代码
咨询离线安装版本

试验性Centos/Ubuntu/Debian安装命令 独立运行环境(py3.7) 可能存在少量兼容性问题 不断优化中  
  1. curl -sSO http://download.bt.cn/install/install_panel.sh && bash install_panel.sh
复制代码

Ubuntu/Deepin安装命令:
  1. wget -O install.sh http://download.bt.cn/install/install-ubuntu_6.0.sh && sudo bash install.sh
复制代码
Debian安装命令:
  1. wget -O install.sh http://download.bt.cn/install/install-ubuntu_6.0.sh && bash install.sh
复制代码
Fedora安装命令:
  1. wget -O install.sh http://download.bt.cn/install/install_6.0.sh && bash install.sh
复制代码

Linux面板7.9.3升级命令:
  1. curl https://download.bt.cn/install/update_panel.sh|bash
复制代码

国产龙芯架构CPU安装命令,支持龙芯架构的loongnix 8.3、统信UOS 20、kylin v10系统
  1. wget -O install_panel.sh http://download.bt.cn/install/0/loongarch64/loongarch64_install_panel.sh && bash install_panel.sh 12f2c1d72
复制代码

以上节点无法使用的情况下,请使用下面的备用节点:

备用节点【香港】:(宝塔推荐使用CN2 双程GIA高品质,免备案的尊云zun.com香港云服务器安装)
  1. yum install -y wget && wget -O install.sh http://116.213.43.206:5880/install/install_6.0.sh && sh install.sh
复制代码

备用节点【美国】:(宝塔推荐使用价格厚道,高性能v4的尊云zun.comKVM云服务器安装)
  1. yum install -y wget && wget -O install.sh http://128.1.164.196:5880/install/install_6.0.sh && sh install.sh
复制代码

若点击更新后没生效,请尝试重启面板服务:
  1. bt restart
复制代码
面板特色功能:
  • 一键配置服务器环境(LAMP/LNMP)
  • 一键安全重启
  • 一键创建管理网站、ftp、数据库
  • 一键部署SSL证书
  • 一键部署源码(discuz、wordpress、dedecms、z-blog、微擎等等)
  • 一键配置(定期备份、数据导入、伪静态、301、SSL、子目录、反向代理、切换PHP版本)
  • 一键安装常用PHP扩展(fileinfo、intl、opcache、imap、memcache、apc、redis、ioncube、imagick)
  • 数据库一键导入导出
  • 系统监控(CPU、内存、磁盘IO、网络IO)
  • 防火墙端口放行
  • SSH开启与关闭及SSH端口更改
  • 禁PING开启或关闭
  • 方便高效的文件管理器(上传、下载、压缩、解压、查看、编辑等等)
  • 计划任务(定期备份、日志切割、shell脚本)
  • 软件管理(一键安装、卸载、版本切换)

面板管理常用命令:https://www.bt.cn/btcode.html


7.9.3更新日志:
【增加】增加Docker模块
【增加】增加Go项目模型
【增加】增加通用项目模型
【增加】增加SqlServer数据库管理模型
【增加】增加MongoDB数据库管理模型
【增加】增加Redis数据库管理模型
【重构】重构消息推送通道(邮件、钉钉、企业微信、短信)
【重构】重构模块加载器提升加载效率,减少通信故障
【优化】优化SSL证书模块
【优化】优化面板主体对loongarch64、aarch64架构的兼容性
【优化】优化读取3M以上的文件问题
【优化】ACME模块增加支持新的地区域名
【调整】调整在线客服按钮功能
【调整】调整一键部署默认数据库编码为utf8mb4
【修复】修复解压后权限问题
【修复】修复部分机器redis无法卸载的问题
【修复】修复pma4.0/4.4在面板端口修改后访问问题
【修复】修复不同目录同名缩略图缓存问题
【修复】修复IPv6机器的通信兼容
【修复】修复CloudFlare接口取回域名数量只有20条导致的SSL申请失败问题
【修复】其它在测试版已经修复的问题

以下为部分功能预览图:


面板设置


SSL


监控


文件管理


计划任务


软件管理


PHP扩展


一键部署源码


服务器跑分


日志清理


宝塔终端


以上为部分功能界面截图,如需了解更多,敬请安装体验,一行代码,2分钟能装好。





使用道具 举报 只看该作者 回复
推荐
发表于 2018-11-23 14:01:37 | 只看该作者
把面板里 php5.2,php5.3和php5.4还有mysql5.1这些老版本都取消吧。现在没有多少新的程序用这些老版本了。

香港/美国高性能云服务器27元起秒杀专场,上云必备,火爆开抢 https://www.56dr.com  发表于 2022-3-24 16:13
星辰云服务器 低价 高防 有盾的云服务器 https://www.callnop.com  发表于 2022-3-13 21:33
皇冠云 5m带宽19元起! https://www.idchg.com  发表于 2022-2-27 00:38
玖毅云服务器 低价 高防 有盾的云服务器 https://www.jyyidc.com/server/buy.html  发表于 2021-12-24 08:17
恭喜本贴子 已经200多万浏览了 支持 宝塔 https://www.jyyidc.com/server/buy.html  发表于 2021-12-16 22:52
使用道具 举报 回复 支持 5 反对 94
推荐
发表于 2019-12-19 10:28:53 | 只看该作者
wzcxyz 发表于 2018-11-23 14:01
把面板里 php5.2,php5.3和php5.4还有mysql5.1这些老版本都取消吧。现在没有多少新的程序用这些老版本了。 ...

讲真,你这种人就是SD,万一哪个公司就是用这个版本呢,你这人真是脑子有毛病
使用道具 举报 回复 支持 27 反对 1
推荐
发表于 2018-11-26 08:23:09 | 只看该作者
wzcxyz 发表于 2018-11-23 14:01
把面板里 php5.2,php5.3和php5.4还有mysql5.1这些老版本都取消吧。现在没有多少新的程序用这些老版本了。 ...

你用不到不代表别人用不到,php5.2到5.4还有好多老程序在用这些php版本,你用不到可以不安装!

yum install -y wget && wget -O install.sh http://download.bt.cn/install/install_6.0.sh && sh install.sh a0cd811a0  发表于 2021-11-7 08:03
使用道具 举报 回复 支持 25 反对 0
推荐
发表于 2018-11-17 17:57:43
[i=s] 本帖最后由 xmm199328 于 2018-11-19 14:06 编辑 [/i]

6.5版本安装mysql5.7后显示未安装
安装完成后宝塔界面显示未安装,使用命令查看mysq也无法连接
支持 21 反对 0
推荐
发表于 2021-10-2 00:05:49 | 只看该作者
宝塔用了好几年,最近开始强制登录了。说真的登陆不登陆无所谓,你想收集用户信息大可后台悄咪咪去搜集,现在一句 “很多功能实现依赖官网”就强制登录你不觉得再侮辱用户智商?依赖官网跟登录有关系?当年宝塔融资几个月就花光的日子已经过去了,开始伸手了?你想做什么那是你的事,麻烦能不那么光明正大的侮辱用户智商可以吗?
使用道具 举报 回复 支持 16 反对 1
推荐
发表于 2020-6-29 11:34:49 | 只看该作者
wzcxyz 发表于 2018-11-23 14:01
把面板里 php5.2,php5.3和php5.4还有mysql5.1这些老版本都取消吧。现在没有多少新的程序用这些老版本了。 ...

你这种人脑子是不是有坑?
使用道具 举报 回复 支持 8 反对 0
推荐
发表于 2019-4-9 18:26:23 | 只看该作者
好多问题啊,计划任务不执行, shell脚本失效
使用道具 举报 回复 支持 6 反对 0
推荐
发表于 2019-5-23 15:07:38 | 只看该作者
本帖最后由 mrwu888 于 2022-9-11 22:58 编辑

面板及时更新 很好的满足用户的需求
使用道具 举报 回复 支持 5 反对 0
推荐
发表于 2018-11-20 23:38:47 | 只看该作者
经测试,宝塔6.5面板本身已经能兼容深度15.8。
可惜在宝塔面板安装任意一个服务器环境软件后,就会让深度桌面的电源管理界面失效,无法关机或重启。
通过命令重启后,启动界面停留在MODSIGN: Couldn't get UEFI db list的报错提示上,虽然宝塔本身不考虑桌面版LINUX,但要是能兼容解决一下就好了。
使用道具 举报 回复 支持 4 反对 0
推荐
发表于 2020-11-4 19:33:35 | 只看该作者
一直在用,宝塔面板真的很好用,也推荐给了很多身边的朋友,支持宝塔!
使用道具 举报 回复 支持 3 反对 0
12#
发表于 2018-11-16 20:50:34 | 只看该作者
什么情况,6.6?前排支持!
使用道具 举报 回复 支持 1 反对 0
13#
发表于 2018-11-17 10:57:57 | 只看该作者
宝塔linux6.0以上版本是基于centos7 开发,强烈推荐大家使用centos7系统(例如centos7.4)安装宝塔linux 6.0以上版本。
使用道具 举报 回复 支持 0 反对 2
14#
发表于 2018-11-18 17:04:20 | 只看该作者
本帖最后由 痞子哥 于 2020-4-12 16:03 编辑

宝塔终端简直是太给力了。

超高性价比 腾讯云服务器1折起

这是新版本加入的新功能  发表于 2018-11-19 13:29
使用道具 举报 回复 支持 2 反对 0
15#
发表于 2018-11-19 15:47:48 | 只看该作者
这是我最近看到唯一让我高兴的事儿

感恩认可 这版本重写架构还增加了很多新功能  发表于 2018-11-21 17:47
使用道具 举报 回复 支持 反对
16#
发表于 2018-11-19 17:20:46 | 只看该作者
本帖最后由 1501867045noqo 于 2018-11-19 17:25 编辑

很棒,不过树莓派上 Centos7 安装成功,bt start 执行也成功,但是无法访问 8888 端口,是还不兼容树莓派吗?老板版本可以的,我是卸载了老版本后重新安装的。
CentOS Linux release 7.5.1804 (Core)
使用道具 举报 回复 支持 2 反对 0
17#
发表于 2018-11-19 20:30:34 | 只看该作者
本帖最后由 MeowLove 于 2018-12-5 10:40 编辑

支持一下!终于发布宝塔6.X版!继续发展,看好宝塔!
------------------------------------------------------------------------------------------------------
宝塔安装和使用途中遇到疑难杂症可以看看这个
[宝塔首发教程] 一键安装 最新 纯净 CentOS 7 / Windows Server 2019 系统

使用道具 举报 回复 支持 反对
18#
发表于 2018-11-19 21:07:18 | 只看该作者
升级后面板打不开了
使用道具 举报 回复 支持 1 反对 0
19#
发表于 2018-11-19 23:43:42 | 只看该作者
说真的,特别不喜欢在安装文件里面悄悄的帮你把pip源改成豆瓣
使用道具 举报 回复 支持 反对
20#
发表于 2018-11-20 09:54:48 | 只看该作者
Ubuntu平滑升级什么时候来?
使用道具 举报 回复 支持 1 反对 0
21#
发表于 2018-11-20 10:16:32 | 只看该作者
aishlai 发表于 2018-11-20 09:54
Ubuntu平滑升级什么时候来?

同问,ubuntu可以升级了不?
使用道具 举报 回复 支持 反对
22#
发表于 2018-11-20 14:43:15 | 只看该作者
为啥我的还是5.9版呢?这个6.5的需要手动升级吗?不推送?
使用道具 举报 回复 支持 反对
23#
发表于 2018-11-20 23:40:12 | 只看该作者
有多少人做了平滑升级的操作的呢。我的还是5.9。点更新说是最新版了。手动升级吗?多少人升级了。投个票。决定升级不。已经生产环境了。
使用道具 举报 回复 支持 1 反对 0
24#
发表于 2018-11-21 19:49:57 | 只看该作者
python3.4 install error!

刚刚安装,装不了
使用道具 举报 回复 支持 反对
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表