当前位置:论坛首页 > Linux面板 > Linux面板教程

宝塔Linux7.8.0面板CPU、内存负载异常或卡顿的解决方法

发表在 Linux面板2021-12-31 16:40 [复制链接] 29 2058

近期有部分Linux面板升级到7.8.0的用户对服务器的CPU、内存负载高或卡顿感到疑问

经过排查发现,这部分用户都是装了较旧的php5.2版本,由于php5.2只生成php-cgi静态进程,并且不会自动释放,如果装了php守护插件遇到问题就又会重新开一个进程,导致无限开进程,就会有可能导致服务器CPU、内存跑满,随后服务器宕机。

优化后用户端的处理方法:
卸载php守护插件,随后更新面板到7.8.0或最新测试版,已经是的请修复面板,操作都做完后,重装php守护插件即可。
未安装php守护插件的用户,已经是7.8.0及以上的面板,请修复面板后,将所有的php-cgi进程杀掉,重启php即可。
  1. pkill php-cgi && /etc/init.d/php-fpm-52 restart
复制代码

*此方法仅适用于装了php守护或安装了php5.2的面板


其他非此类问题的用户,如果出现CPU、内存或负载高,请前往软件商店-->安装宝塔任务管理器-->点击CPU或内存倒序并截图上传附件另外发帖求助。
QQ截图20211231163840.jpg

如果您是免费用户,请登录服务器终端,执行下面的命令安装htop并截图
  1. # centos alibabcloud 等使用yum的用户
  2. yum install -y htop && htop
  3. # debian ubuntu等使用apt的用户
  4. apt install -y htop && htop
复制代码
QQ截图20211231163958.jpg



使用道具 举报 只看该作者 回复
发表于 2022-1-11 14:20:55 | 显示全部楼层
我的就是这个问题,内存爆满,数据报错,害的我重新换服务器,重新部署环境 。网站直接停1天。坑死
使用道具 举报 回复 支持 1 反对 0
发表于 2021-12-31 17:33:49 | 显示全部楼层
小白弱弱问一句,怎么卸载php守护插件??
使用道具 举报 回复 支持 反对
发表于 2021-12-31 18:27:50 | 显示全部楼层
宝塔用户_nirevg 发表于 2021-12-31 17:33
小白弱弱问一句,怎么卸载php守护插件??

软件商店--搜索php守护,如果已经装了才有卸载,没有就不用
使用道具 举报 回复 支持 反对
发表于 2022-1-1 14:24:36 | 显示全部楼层
我没装PHP守护,以前装了PHP5.2,我把5.2卸载了试试
使用道具 举报 回复 支持 反对
发表于 2022-1-1 16:34:36 | 显示全部楼层
怎么安装7.7呀 ,用不了7.8呀
使用道具 举报 回复 支持 反对
发表于 2022-1-3 22:48:43 | 显示全部楼层
没有安装php守护,还是出现你这种情况,内存爆满,mysql自动关闭,所有网站瘫痪!
使用道具 举报 回复 支持 反对
发表于 2022-1-4 15:35:07 | 显示全部楼层
调侃:更新以后,确实卡
使用道具 举报 回复 支持 反对
发表于 2022-1-5 12:03:05 | 显示全部楼层
宝塔用户_onbpqw 发表于 2022-1-3 22:48
没有安装php守护,还是出现你这种情况,内存爆满,mysql自动关闭,所有网站瘫痪! ...

您好,能否私聊发下您的面板登录信息,排查下是什么问题导致的?
使用道具 举报 回复 支持 反对
发表于 2022-1-5 17:44:39 | 显示全部楼层
更新7.8.0以后卡爆了。
开启Nginx,CPU和内存直接爆满
使用道具 举报 回复 支持 反对
发表于 2022-1-5 18:55:50 | 显示全部楼层
fly2020 发表于 2022-1-5 17:44
更新7.8.0以后卡爆了。
开启Nginx,CPU和内存直接爆满

我猜是被CC攻击了,建议查看网站日志分析,如果确实是被攻击了,安装nginx防火墙,把CC防御规则调整为增强模式试试
使用道具 举报 回复 支持 反对
发表于 2022-1-5 20:20:03 | 显示全部楼层
堡塔安全赤井秀一 发表于 2022-1-5 18:55
我猜是被CC攻击了,建议查看网站日志分析,如果确实是被攻击了,安装nginx防火墙,把CC防御规则调整为增 ...

确定是升级7.8.0的问题
安装nginx防火墙,防火墙并未检测到共计
使用道具 举报 回复 支持 反对
发表于 2022-1-8 09:59:57 | 显示全部楼层
fly2020 发表于 2022-1-5 20:20
确定是升级7.8.0的问题
安装nginx防火墙,防火墙并未检测到共计
  1. pkill php-cgi && /etc/init.d/php-fpm-52 restart
复制代码

尝试执行这条命令后再试试
使用道具 举报 回复 支持 反对
发表于 2022-1-11 11:01:59 | 显示全部楼层
确实升级了7.8 就负载满了, 官方直接修复一下不好么
使用道具 举报 回复 支持 反对
发表于 2022-1-11 14:21:31 | 显示全部楼层
事实证明,没事不要升级。
使用道具 举报 回复 支持 反对
12下一页
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表