当前位置:论坛首页 > Linux面板 > 讨论

【已解答】网站一直提示上传出错

发表在 Linux面板2022-3-23 01:36 [复制链接] 1 3233

网站一直提示上传出错,调整上传限制为500兆,php中修改为post_max_size=500M、upload_max_filesize=500M、max_execution_time=300、default_socket_timeout=300,仍然上传错误,修改nginx中的client_max_body_size 500m,还是上传错误,150M的文件,上传到2%就提示失败。
背景:前面老是出错,php进程一直增加导致死机,于是新装centos8steam系统,新装宝塔7.9稳定最新版,环境如下:
Tengine2.2.4
mysql5.7.37
php5.6
系统防火墙
nginx免费防火墙
经过各种排查,发现nginx免费防火墙拦截post渗透15次,于是关闭该防火墙,问题解决
更新:
但是新问题出现了,刚刚进宝塔后台,发现进不去,ssh也连不上,腾讯云看到服务器在运行中,cpu满负载。
重启继续监控,发现php进程一直在升高,远远高于我设置的最多30个子进程,请大神帮忙看看了


使用道具 举报 只看该作者 回复
发表于 2022-3-23 09:23:15 | 显示全部楼层
你好,根据反馈的信息分析,做出下面2个解析

1.网上上传文件出错,免费防火墙拦截,是因为触发了免费防火墙的防御规则,所以拦截了;免费防火墙并非我司开发,由第三方开发者开发维护,建议联系第三方开发者沟通处理;
https://www.bt.cn/bbs/thread-39649-1-1.html

2.ssh登不上,面板进不去,控制台看到cpu满载,php进程跑满;这个极大原因是网站被攻击,导致php进程不断新增,这一方面也有代码没优化好的成分,建议把php慢日志出现的全部给程序员优化一下;
关于CC攻击,建议打开专业版的nginx防火墙,查看是否存在被攻击的记录,尝试将nginx防火墙的cc防御规则调整为增强模式,看cpu是否降下来了
详细设置参考cc防御那一段:https://www.bt.cn/bbs/thread-73847-1-1.html
使用道具 举报 回复 支持 反对
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

紧急运维服务

响应时间:3分钟

问题处理方式:宝塔专家1对1服务

工作时间:工作日:9:00 - 18:30

宝塔专业团队为您解决服务器疑难问题

点击联系技术分析

工作时间:09:00至18:30

快速回复 返回顶部 返回列表